Announcement

Collapse
No announcement yet.

Yocto Course

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Yocto Course

    hi
    what is the problem?
    ( Click image for larger version

Name:	Untitled.jpg
Views:	56
Size:	279.9 KB
ID:	17712 ubuntu 14.04)

  • #2
    Please, what is the version of your Ubuntu? Did you use the same version as I did? I see you are saying 14.04 - but the picture looks different from what I used.

    Comment


    • M. Namvar
      M. Namvar commented
      Editing a comment
      hi Robert
      ubuntu 14.04.6 LTS

  • #3
    [email protected]:~/bin$ cat /etc/os-release
    NAME="Ubuntu"
    VERSION="14.04.6 LTS, Trusty Tahr"
    ID=ubuntu
    ID_LIKE=debian
    PRETTY_NAME="Ubuntu 14.04.6 LTS"
    VERSION_ID="14.04"
    HOME_URL="http://www.ubuntu.com/"
    SUPPORT_URL="http://help.ubuntu.com/"
    BUG_REPORT_URL="http://bugs.launchpad.net/ubuntu/"
    [email protected]:~/bin$ lsb_release -a
    No LSB modules are available.
    Distributor ID: Ubuntu
    Description: Ubuntu 14.04.6 LTS
    Release: 14.04
    Codename: trusty
    [email protected]:~/bin$ uname -r
    4.4.0-148-generic
    [email protected]:~/bin$

    Comment


    • #4
      I got tired.
      I have neck pain!
      but I never give up.
      Last edited by M. Namvar; 05-31-2021, 09:53 PM.

      Comment


      • #5
        I Fixed that.
        1-Upgrade to ubuntu 14.04.7
        Click image for larger version  Name:	Untitled.jpg Views:	0 Size:	244.9 KB ID:	17763
        then use this :
        $sudo add-apt-repository ppa:deadsnakes/ppa
        $ sudo apt update
        $ sudo apt install python3.6



        https://www.tecmint.com/install-python-in-ubuntu/



        Comment


        • #6
          M. Namvar does it work now? I could try it, but I tried it couple of months ago and it was working. Maybe something has changed - if you can't figure out what the problem is, I will try to install it on my computer.

          Comment


          • #7
            robertferanec Hi
            I can not run Repo init because of the Python version and HTTPS SSL error.
            I tried and tried to install the SSL package. no luck!
            then I upgraded ubuntu to 14.04.7.
            SSL problem solved but installing Python became my new problem.
            after all the above methods worked.

            Comment


            • #8
              if you are behind a proxy server, like me, the repo sync may fail. So use these commands to solve it.

              Setting the proxy for Git
              1. Open a command prompt
              2. Run the following commands replacing USERNAME, PASSWORD, PROXY_ADDRESS, and PROXY_PORT with your network's information:
                1. git config --global --add http.proxy http://USERNAME:[email protected]_ADDRESS:PROXY_PORT
                2. git config --global --add https.proxy http://USERNAME:[email protected]_ADDRESS:PROXY_PORT
              3. Run the following commands to prevent SSH problems:
                1. git config --global url."https://".insteadOf git://
                2. git config --global url."https://github.com/".insteadOf [email protected]: (don't remove the final colon)
              4. If your computer is within a corporate network that uses personal network drives, ensure identical copies of your .gitconfig file exist on both the network drive and your local drive's user profile (e.g. F:\ and C:\Users\USERNAME).

              Source : https://wet-boew.github.io/v4.0-ci/docs/proxy-en.html

              Comment


              • #9
                Thank you so much M. Namvar

                Comment


                • #10
                  meta-fsl-arm-extraerror: Cannot fetch poky from https://git.yoctoproject.org/git/poky

                  Click image for larger version

Name:	Untitled.jpg
Views:	30
Size:	206.1 KB
ID:	17816

                  Comment


                  • #11
                    I had a look into the git:
                    http://git.yoctoproject.org/

                    Maybe try:
                    http://git.yoctoproject.org/cgit/cgit.cgi/poky/

                    Please let me know if that helped. Thank you

                    Comment


                    • M. Namvar
                      M. Namvar commented
                      Editing a comment
                      I face this problem when executing the repo sync command.
                      Do you mean to install poky manually?
                      Last edited by M. Namvar; 06-15-2021, 10:23 PM.

                  • #12
                    I will try to build it when I am at home.

                    PS: Maybe have a look into the manifest file and update link to poky?

                    Comment


                    • #13
                      I just tested it. Only what I had to do was update to python 3.6 ( exactly as you described in https://designhelp.fedevel.com/forum...7762#post17762 ) and then it just worked:

                      Click image for larger version  Name:	repo sync.png Views:	0 Size:	476.7 KB ID:	17861

                      I have not seen any problems with HTTPS and anything else what you were describing in the other posts. After I installed python 3.6, it just worked.

                      Maybe it is something with your Ubuntu installation? Did you try to download the Ubuntu which I created? The link is under the lesson video in Links & Download TAB.

                      Comment


                      • M. Namvar
                        M. Namvar commented
                        Editing a comment
                        hi, I checked. my default python version is 2.7. I will try to change it to 3.6

                    • #14
                      Do not ask me about Yocto, but python 2.x and 3.x are not compatible to each other!

                      Comment

                      Working...
                      X