No announcement yet.

Yocto Course

  • Time
  • Show
Clear All
new posts

  • #31
    I am testing it again. What Ubuntu did you download? This one?


    • rutrilla
      rutrilla commented
      Editing a comment
      Yes, I did everything with that image, the ubuntu-14.04.4-desktop-amd64.iso.

      However, I have noticed that after running the "sudo apt-get upgrade" command indicated in "How to prepare a Host machine for YOCTO", the version is upgraded to 14.04.6 (according to the command: "lsb_release -d").

      Thanks in advance for your help!

  • #32
    So, the problem with the python installation above is, that there is no openssl. I had to do this:

    Install openssl:

    $ wget
    $ tar -xvzf openssl-1.0.2e.tar.gz
    $ cd openssl-1.0.2e.tar.gz
    $ sudo ./config --prefix=/usr/local/openssl --openssldir=/usr/local/openssl
    $ sudo make
    $ sudo make install

    Then install the python:
    $ wget
    $ tar -xvf Python-3.6.3.tgz
    $ cd Python-3.6.3

    Edit config, open
    $nano Modules/Setup.dist

    Search for "ssl" and uncomment and update:

    _socket socketmodule.c

    # Socket module helper for SSL support; you must comment out the other
    # socket line above, and possibly edit the SSL variable:

    _ssl _ssl.c \
    -DUSE_SSL -I$(SSL)/include -I$(SSL)/include/openssl \
    -L$(SSL)/lib -lssl -lcrypto

    Then, save the file and run:

    $ sudo ./configure
    $ sudo make
    $ sudo make install

    To test python and ssl run python3 and write there import ssl, it should look like this:
    fedevel@fedevel-VirtualBox:~/fsl-community-bsp/Python-3.6.3$ python3
    Python 3.6.3 (default, Jan 20 2022, 23:45:09)
    [GCC 4.8.4] on linux
    Type "help", "copyright", "credits" or "license" for more information.
    >>> import ssl

    Then go back to to fsl-community-bsp directory and try again:
    repo init -u -b jethro

    I hope this helps. Midnight, time to go to bed ....

    Click image for larger version

Name:	sync done.png
Views:	141
Size:	262.6 KB
ID:	18966


    • #33
      Well, I reinstalled Ubuntu and follow all the instructions step-by-step.

      I got the following problem with "$ wget", but I downloaded the file from Firefox as a workaround.

      Click image for larger version

Name:	error_wget_openssl.png
Views:	87
Size:	61.7 KB
ID:	18971

      Then, I was able to properly install openssl and python3.6, but I still have problems with the repo init command.

      Click image for larger version

Name:	error_repo_init_certificate_verify_failed.png
Views:	107
Size:	50.1 KB
ID:	18970

      I've tried the rest of your instructions and some others I've found googling the error (export PYTHONHTTPSVERIFY=0 and others), but no lucky...


      • #34
        After you have python working, try to re-run all these, that is what I did and it worked:

        Disable certificates
        export GIT_SSL_NO_VERIFY=1

        If you keep having problems with certificates:
        sudo dpkg-reconfigure ca-certificates
        sudo update-ca-certificates

        Update curl
        sudo nano /etc/apt/sources.list

        Into sources.list insert
        deb xenial-security main
        deb xenial main universe

        and then run
        sudo apt-get update
        sudo apt-get install curl

        PS: Here is a different way to go around the python problem (I have not tested it yet, but this should also work):
        export GIT_SSL_NO_VERIFY=1
        cd ~
        mkdir ~/bin
        git clone
        cd git-repo
        git checkout 27da4ddeb9159573e0207f71e4d9b3ae286b5275
        cp repo ../bin
        chmod a+x ~/bin/repo


        • rutrilla
          rutrilla commented
          Editing a comment
          Hi Robert,

          The first part doesn't work for me. I get the same error. However, with the second workaround it seems that I have already been able to execute the "repo init" and "repo sync" commands.

          Unfortunately, today I can no longer continue with the course. I will keep you informed of my progress in the coming days.

          Thanks for your help!

      • #35
        rutrilla fantastic! Please keep me posted.
        Clement please let me know if it helped to you too. Thank you.