No announcement yet.

Lesson2: python 2 no longer supported error

  • Time
  • Show
Clear All
new posts

  • Lesson2: python 2 no longer supported error

    After deleting fsl-community-bsp directory, followed steps in openrex->how to startwith software, lesson2; please find 2 snapshorts attached. error is related to 1.59th minute, where I execute the repo init command, what is the workaround for this? Thank you.
    Attached Files

  • #2
    Hello meera,

    I tried the first 2 lessons step by step just a week ago and it worked for me. Please, have a look at this document:

    I ran into a similar issue as you describe at the beginning of lesson 2. Right away, I tried the very same fix that worked in the first lesson, however it did not work for lesson 2 for the first time.

    I rebooted the virtual machine and I tried to fix the Python version issue with the very same command lines from the earlier again:
    export GIT_SSL_NO_VERIFY=1
    cd ~
    mkdir ~/bin
    git clone
    cd git-repo
    git checkout 27da4ddeb9159573e0207f71e4d9b3ae286b5275
    cp repo ../bin
    chmod a+x ~/bin/repo

    Re-entering the repo command lines:
    mkdir fsl-community-bsp
    cd fsl-community-bsp
    repo init -u -b jethro

    It worked! Please try to reboot your virtual machine, follow the instructions again and let me know if it works for you as well.

    Thank you​


    • #3
      It worked for me too. Thank you


      • #4
        now am facing error after repo sync command. Please find snapshorts attached.
        Attached Files


        • #5
          Maybe try later again? This could be internet problem (?)


          • #6
            Hello meera,

            Could you please confirm if you can access the document below? This document describes situations you may run into that are not shown in the course video:

            Thank you​


            • #7
              yes, am able to access the document from above link.


              • #8
                Originally posted by meera
                yes, am able to access the document from above link.

                If you have look at L2: 00:03:24 section in the previously attached document, you will find the notes about this topic and also about some other issues you may run into:

                When trying to download the files with command:
                repo sync

                I got the very same error as you do:
                Fetching projects: 87% (7/8) pokyfatal: unable to connect to
      [0:]: errno=Connection timed out

                fatal: unable to connect to
      [0:]: errno=Connection timed out

                error: Cannot fetch meta-openrex from git://
                Fetching projects: 100% (8/8), done.
                error: Cannot checkout meta-openrex: ManifestInvalidRevisionError: revision jethro in meta-openrex not found
                error: in `sync`: revision jethro in meta-openrex not found

                The problem was the git port is restricted ( Fixed this with following command:
                git config --global url. git://

                The second attempt of downloading (rest of the) files with:
                repo sync

                It worked out:
                fedevel@fedevel-VirtualBox:~/fsl-community-bsp$ repo sync

                ... A new repo command ( 1.27) is available.
                ... You should upgrade soon:
                cp /home/fedevel/fsl-community-bsp/.repo/repo/repo /home/fedevel/bin/repo

                Fetching projects: 75% (6/8) meta-fsl-armremote: Enumerating objects: 160, done.
                remote: Total 160 (delta 0), reused 0 (delta 0), pack-reused 160
                Receiving objects: 100% (160/160), 58.64 KiB | 0 bytes/s, done.
                Resolving deltas: 100% (68/68), done.
                * [new branch] jethro -> fedevel/jethro
                * [new branch] master -> fedevel/master
                Fetching projects: 100% (8/8), done.


                • #9
                  today I have been trying the above fix for repo-sync. I directly followed the steps given in "L1-L2 process double checked" page. It still doesnt work, the same "pokyfatal" error I got. Th solution, I found by in net and it is the following. In the openrex-> how to start with software page, in
                  cat > .repo/local_manifests/imx6openrex.xml << EOF

                  <?xml version="1.0" encoding="UTF-8"?>


                  <remote fetch="git://" name="fedevel"/>

                  <project remote="fedevel" revision="jethro" name="meta-openrex" path="sources/meta-openrex">

                  <copyfile src="" dest=""/>




                  instead of using <remote fetch="git://" name="fedevel"/>, use <remote fetch="" name="fedevel"/>,
                  after that it worked. PFA snapsots (the solvedpoky snapshot).
                  Attached Files


                  • #10
                    OK. I have just seen your post, after I posted. I was looking at the Thank you


                    • #11
                      This is a query in Lesson 2, at around 4.48 minutes. When you say " your board needs to be similar to the reference board", what it means? I have a situation, where I have two reference boards (board1 & board2), both having cortex-a9 core based processor from 2 different manufacturers. the third board is the board on which I need to port uboot, it has processor from the second board and other hardware from the first board. how should i proceed with developing uboot for the third board. Thanks


                      • #12
                        continuing towards bit command. pfa snapshots, bitbake failed. I am trying for solution from my end too.
                        Attached Files


                        • #13
                          meera is it working now?