No announcement yet.

learn the essenials of creating uboot..- Failed to install VM extension pack

  • Time
  • Show
Clear All
new posts

  • learn the essenials of creating uboot..- Failed to install VM extension pack

    I am in the first lesson of learn the essenials of creating uboot, linux and yocto course.
    The extension pack is failed to install on my VM.
    Kindly advice.


  • #2
    please, did you follow the instructions in the Updates TAB? PS: I apologize for late reply I am on vacation


    • #3
      I have setup complete new machine with Linux 14.4 just top avoid any VM issues.


      • #4
        there is new error I am getting.
        can you help me.
        this seems related to python, installed version of pythons are python 2.7.6 and python 3.4.3
        I cannot install 3.6 or later, it shows error that couldn't fina any packages by regex 'python3.6'

        Click image for larger version

Name:	Error2.png
Views:	29
Size:	174.6 KB
ID:	21988


        • #5
          please, did you follow the exact steps in the Updates TAB?


          • #6
            Hello onkar,

            Please, have you solved the outdated Python version issue?

            Last time I tried to follow the first 2 lessons step by step I managed to make it work. Please, have a look at this document, it might be useful for you:

            During my testing, I ran into a similar issue as you describe in lesson 1 with the repo init command. After entering following command in the terminal:
            Following error shows up:
            fedevel@fedevel-VirtualBox:~/fsl-community-bsp$ repo init -u -b jethro
            repo: error: Python 2 is no longer supported; Please upgrade to Python 3.5+.

            Under the course online video, there is a Questions & Updates tab, where you can find instructions on how to fix this issue. Entering following commands into the terminal:
            export GIT_SSL_NO_VERIFY=1
            cd ~
            mkdir ~/bin
            git clone
            cd git-repo
            git checkout 27da4ddeb9159573e0207f71e4d9b3ae286b5275
            cp repo ../bin
            chmod a+x ~/bin/repo

            I tried the repo command again. I entered following commands:
            cd fsl-community-bsp
            git config --global "[email protected]"
            git config --global "yourname"
            repo init -u -b jethro

            It worked!

            Please try to reboot your virtual machine, follow the instructions again and let me know if it works for you as well.

            Thank you​​