Announcement

Collapse
No announcement yet.

Altium 2018 errors when transferring the schematic to PCB

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Altium 2018 errors when transferring the schematic to PCB

    Hi,

    I am getting these errors (see the files attached) when I am trying to update my schematic to the PCB. Do you have an idea why? Although after I validate them, they seem to be on the PCB.

    I have seen this issue in the past versions, but it didn't affect me hence I ignored it, but right now I would like to know the reason for this issue, just to be sure that it will not affect my PCB later or if its just a bug.

    Thanks,
    Mihai

  • #2
    you can try and do this:


    in the schemtatic go and reset unique ID's
    update from library
    after that update to the PCB and try and update your component links..

    in you first image it looks like there is no footprint or altium does not know the footprint.. the second i am not sure.. it is trying to add classmembers to a non excisiting class.
    that can happen when you add a class manually in the pcb doc. if you update from schematic (and if your class is not in the schemativc) it will delete it

    Comment


    • #3
      Hi,

      Indeed for the first one, there was issue with the footprint as you said. The second one, I dont know yet, but I does not bother me, hence I will try to figure out later. I just asked maybe some of you know about it.

      Many thanks,
      Mihai

      Comment


      • #4
        I can't see the whole error message about the components - is it about component classes? I do not use component classes. You can disable it in Project -> Project Options -> Class Generation and uncheck Component classes for every schematic page.

        Click image for larger version

Name:	ucheck component classes.jpg
Views:	32
Size:	130.6 KB
ID:	10456

        Comment


        • #5
          Hi Robert,

          You were right, that was the problem. Thanks.

          Cheers,
          Mihai

          Comment

          Working...
          X