Announcement

Collapse
No announcement yet.

Help with External Table Error with Altium BOM

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Help with External Table Error with Altium BOM

    Hello everyone! I'm fairly new to Altium Designer and I am having some trouble creating a BOM for my design. I have added a new BOM document to the project by right clicking on the project name in the projects windows and everything there works fine. However, when I try to generate a BOM from the reports tab, I receive an error saying:
    'The external table is not in expected format. Exception Occurred in GenerateReport'
    If I try to generate a Simple BOM from the Reports tab, it thinks for a while and then nothing happens. Does anyone know what this means and how I can fix it? I've done alot of searching online and can't seem to find any information on it. Thanks so much!
    Thanks,
    https://diceus.com/10-ways-can-decei...velopers-2018/
    Last edited by Kanch; 04-22-2019, 10:29 PM.

  • #2
    Hard to tell what's going on, can you post the project or a reduced version of it that is not secret ?

    this error sounds like an error that is usually returned from excel / odbc, so perhaps try to make sure your excel is up to date and functional




    Last edited by anovickis; 04-18-2019, 12:10 PM.

    Comment


    • #3
      you have to make sure that the items (text field names) in your template are exactly the same as in altium. check out some of the defaults in altium you should be able to find the mistake and correct it

      Comment


      • #4
        Maybe this could help? I made a video about how to generate outputs, including BOM: https://www.youtube.com/watch?v=W21dORx5ceI

        Comment

        Working...
        X