Announcement

Collapse
No announcement yet.

how to show the nets of components

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • how to show the nets of components

    hello everyone, i'm learning the Advanced PCB Layout course,in Lesson 1 when i placement the connector J1 or J2 , the nets didn't show,but other components are ok.what's going on?my altium designer version is 20.0.9
    Click image for larger version  Name:	with no nets.png Views:	0 Size:	8.4 KB ID:	12825


    Click image for larger version  Name:	with nets.png Views:	0 Size:	35.4 KB ID:	12826
    Last edited by MrSun; 01-04-2020, 07:04 AM.

  • #2
    Hello MrSun ,
    From the 2nd Image that you have attached.. It seems that Pin10 of Quad IC is connected to One of the Pins on the connector which indicates that the nets are being identified by the Altium.

    Some points you can try:
    1. Try zooming in on to the connector and nets shall appear
    2. Check if there any compilation error. With Atlium 20, they have an auto compile engine hence Right click on the PCB Project and Click "Validate"
    3. Try cross probing the Pins on the PCB and check if they indicate to the corresponding pin in the schematic
    Share the results of above and this should help us to help you better.

    Thanks.

    Comment


    • MrSun
      MrSun commented
      Editing a comment
      thank you,please reference robertferanec 's answer .

  • #3
    There is a limit in Altium for components with many pins - when a component has more pins then the limit is set to, it will not show the nets. To change the limit go to System Preferences -> System -> General -> Advanced ... button -> PCB.ComponentDrag.ConnectionLimit and increase the number:

    Click image for larger version

Name:	connection limit altium.png
Views:	53
Size:	103.8 KB
ID:	12833

    Comment


    • MrSun
      MrSun commented
      Editing a comment
      Thank you very much for your detailed answers.

  • #4
    I never knew this! thanks

    Comment

    Working...
    X