Announcement

Collapse
No announcement yet.

Question - Essentials 2nd Ed.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Question - Essentials 2nd Ed.

    I’m working through lesson 4 of the Altium Essentials 2nd Ed. and am having a disconnect midway through the lesson regarding the layer stack and the net assignment to the two planes. First, when adding the extra internal layers the layer stack manager seems to be assigning them as a substack which doesn’t seem to be what I observe in the video. The PCB in the video shows all 6 copper layers on the board layer stack where I have all new layers assigned to board layer stack with an error that the layer stack name is the same, see Pic1 attached. Second, when the plane is assigned to a net I do not observe the copper removal for the negative plane nor the relief connections like what is shown in the video.

    Hopefully this is enough to diagnose or direct me to a post on your forum.

    Regards,

    Cooper

  • #2
    Should this be posted somewhere else or should I be adding more information to this post?

    Comment


    • #3
      It looks like the copper removal works - it is the green line around your board, however you should see there green layer - I am not sure why yo do not see it. It should look like on the picture below. Be sure you have all the layers enabled (Steps 1-2-3) and then click on the Layer TAB (Step 4) to select the layer.

      Click image for larger version  Name:	show all layers altium 1.PNG Views:	1 Size:	118.8 KB ID:	13558

      Comment


      • #4
        Still not seeing it correctly, any other ideas? Could i provide you with something else that might make this easier to TS?

        Comment


        • #5
          What i see in your first picture is you have a stack problem (there is a red outline in the combo box). It looks like you have 2 stack in conflict. Click the combo box and select the other stack and delete it.

          Comment


          • #6
            What I wasn't expecting, following the instructions, is that when I created the additional layers the substack option was something that appears to be auto-assigned. I have changed the substack name for the added layers which removes the error. I have also tried to turn substack feature off. Either way the plane layer stayed the same. Could this possibly be something in the design rules?

            Comment


            • #7
              If you select the layer of your plane and then double click on it, a split plane dialog box will appear where you select the Net, in your case select GND

              Comment


              • #8
                (there is a red outline in the combo box)
                - great spot CLaFond, I completely missed that.

                willyduke as CLaFond suggested, did you try double click into the black area? I would really expect it should work.

                Comment


                • #9
                  So I used the post from stack exchange below to resolve the stack errors,

                  https://electronics.stackexchange.co...from-altium-19

                  However, this still doesnt fix the plane issue as you can see in the attached photos. Double-clicking in the black area doesn't bring up the layer properties window where I can set its net. The net for both planes was already set to GND by double clicking on the layers tab (not the black area) at the bottom of the window. One thing I notice from Roberts example is that before he double-clicks the plane to set the plane net it appears to have a green/red hue over the black area. Its only when selected to change the net that it has the dark black plane color. This is how it is by default.

                  Comment


                  • #10
                    Another observation is there is no clearance around the pads that are not GND.

                    Comment


                    • #11
                      Looking at what willyduke said about split plane I think the split count should be one for L2 and L5 instead of 0. That correct?

                      Comment


                      • #12
                        Yeah, that is weird, at least should be one split, maybe trying to delete the layers and create them again? or using the layers presets?

                        Comment


                        • #13
                          Looks like I worked it out. It seems like the issue was that I had a substack over a substack. I moved the created layers over to the default "board layer substack" then deleted the other stack that had the same layers but used a different substack name. Once that was done, all layers were on the "board layer stack" (no more substacks) and the split plane editor showed a count of 1 for L2 and L5. Everything appears to be working correctly and inline with the training now. I think originally I was working through some Altium training months ago that used a ridged/flex pcb design. Some of the settings might have defaulted me to the to the substacks from my usage of that project, at least thats the hypothesis. Anyways, thanks for the help and feedback.

                          Comment


                          • #14
                            CLaFond Awesome! Thank you willyduke for help.

                            Comment


                            • #15
                              Originally posted by CLaFond View Post
                              Looks like I worked it out. It seems like the issue was that I had a substack over a substack. I moved the created layers over to the default "board layer substack" then deleted the other stack that had the same layers but used a different substack name. Once that was done, all layers were on the "board layer stack" (no more substacks) and the split plane editor showed a count of 1 for L2 and L5. Everything appears to be working correctly and inline with the training now. I think originally I was working through some Altium training months ago that used a ridged/flex pcb design. Some of the settings might have defaulted me to the to the substacks from my usage of that project, at least thats the hypothesis. Anyways, thanks for the help and feedback.
                              Hi there, I have the same problem here. I am currently doing the "Learn Altium Essentials Second Edition" course and I am not able to get rid of the second layer stack. I was able to contineu working, by duplicating the layers in both stacks, however I am not sure if this could be a problem once I want to manufacture a board. Do you have how to get rid of the other substacks and keep only one?
                              Every time I try to get rid of the duplicated stack by unchecking the option of Rigid/Flex in the Layer Stack Manager, I keep seeing the two stacks in the PCB panel, and there is no option (or I cant find it) to eliminate one of this substacks.
                              Any help will be appreciated, thanks!

                              Two sub-stacks
                              Two sub-stacks

                              Comment

                              Working...
                              X