Announcement

Collapse
No announcement yet.

Track clearance with flex region cutout in Altium Designer

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Track clearance with flex region cutout in Altium Designer

    In Altium Designer, I created a simple rigid-flex board with the 4 layers in the rigid part (top, in1, in2, bottom) and 2 layers in the flexible part (in1, in2).

    I set 5mm clearance on a top layer track by means of a simple rule. On the rigid board, the track doesn't have 5mm clearance with respect to the board outline (which is the correct behaviour), but it has 5mm clearance with respect to the split line that divides the rigid part from the flex part.

    Said in other words: I can route the track up to the very board border, except when it is a rigid-flex border.

    How do I remove the 5mm clearance with respect to the border between the rigid and the flex part?

    Click image for larger version

Name:	esempio.png
Views:	85
Size:	21.0 KB
ID:	14327


    The error I get is "Celarance contraint between track on TopLayer and PolyRegion on MultiLater":
    Click image for larger version

Name:	error.png
Views:	73
Size:	44.4 KB
ID:	14328


    The net with the problem has class1 class; I set a simple 5mm clearance rule on this class. All other rules are set to Altium defaults:
    Click image for larger version

Name:	rule.png
Views:	71
Size:	53.7 KB
ID:	14329


    The only way I found to remove the clearance violation is to set the clearance matrix as in the picture below, but this is not accepable for a standard circuit:
    Click image for larger version

Name:	soluzione.png
Views:	63
Size:	15.5 KB
ID:	14330





  • #2
    Wrong rule.
    Rules- manufacturing - board outline clearance

    Comment


    • #3
      Thanks for the idea. Already tried to set all Board Outline Clearance to 0, it doesn't work.

      Comment


      • #4
        What poly region does rule refers to?
        Look at Rules and violations panel.

        BTW what is your stackup? most likly one have not flex layers on top.

        Comment


        • #5
          Interesting. I have not had this problem. Maybe try to click on advanced and set region to 0 ... but I am not sure if that is the right way to do it.

          Comment


          • #6
            beamray , No, I don't have the flex no the top. This is my layer stackup:
            Click image for larger version

Name:	Stack.png
Views:	68
Size:	48.6 KB
ID:	14373


            I haven't set up any poly-region rule. Just a simple 5mm clearance rule for the track on top layer. For some reason, Altium considers the border between RIGID and FLEX as a poly-region, and therefore applies the clearance rule.

            You can find attached the example project.

            robertferanec the only way I can disable the error is shown in the rule-matrix I posted before (last image of my first post), but this is not accepable in a design.

            Comment


            • #7
              giacobbe_85, is this your real stackup? I am not sure if that can be manufactured ... did you consult this with your PCB manufacturer?

              Comment

              Working...
              X