No announcement yet.

I can't add a footprint to a symbol

  • Time
  • Show
Clear All
new posts

  • [Solved] I can't add a footprint to a symbol

    Hi all
    I'm following Learn Altium Essentials 2nd ed and I'm stuck at Lesson 4: Doing PCB layout.
    I was progressing with the lesson when I noticed that in the previous step I forgot to associate the footprint to the C8 capacitor symbol. The result is that I don't have its footprint in the pcb now.
    I don't know why I cannot add the footprint to the symbol and moreover I don't know how to update the pcb. Maybe I have to select design --> import changes from project?
    Can anyone help me?
    Here the link to download my project:
    I tried to upload it as 7zip but the action wasn't allowed.
    Last edited by Lucky-Luka; 12-19-2020, 09:59 AM.

  • #2
    Hi all again
    It looks like the late hour affected my mental faculties since I was tring to add a footprint to the wrong capacitor that already had a footprint. Now I thik I managed to correct the problem. Now I cannot hide the rat's nest. view --> connections --> hide all ... and nothing happens...
    Can you please check if my project is correct so far and if I have updated correctly the pcb with the C8 8085 footprint? Maybe it's a bug in my Altium version that affect the proper conections visualization...


    • #3
      I still cannot get rid of rat's nest
      Attached Files


      • #4
        Those lines are from the ERC, and indicate nets that are not routed, to clear the lines, go to the menus "Tools" and select "Reset Error Markers"


        • #5
          Oh, thanks. You are right!