No announcement yet.

Draftsman Issue!

  • Filter
  • Time
  • Show
Clear All
new posts

  • Draftsman Issue!

    Hi Guys,
    Happy 2021! wishing all the best for you!

    In a project, we are using a two-piece EMI shield; in a variant, we set this shield (frame + cover) as DNP. In the 3D view of this variant, it is ok and the EMI shield does not show up. There is a screenshot.
    Click image for larger version

Name:	3D_Variant.png
Views:	591
Size:	151.2 KB
ID:	16236

    But, when I create the Draftmans document for this board output is not as expected. here is a sample.
    Click image for larger version

Name:	Draftsman.png
Views:	422
Size:	828.4 KB
ID:	16242

    If you check the top view, the EMI shield is shown in RED but visible and blocking component beneath. If you check the side view, and front view the EMI shield is not shown, which is correct.
    Do I need to do something or set any parameter to remove DNP parts from the top view, marking them in RED is not helping?

    Attached Files

  • #2
    Hmm, that is interesting. I do not use Draftsman much, but .. I am not sure how to solve this. I guess, you are creating drawing from 3d models, maybe if it is created based on assembly drawing layer, it could maybe help and you could see the components under the shield? However, the red area would probably stay red anyway.

    PS: it looks like there may be some transparency options, but I do not know if that could help:


    • #3
      "PS: it looks like there may be some transparency options, but I do not know if that could help"
      Thank you Robert, your suggestion is correct and fixed the case, non-fitted parts are gone now.


      • #4
        Hi Johnson Miller, I have the same "Red DNP" issue you had. What transparency setting fixed it?


        • #5
          Here's where the DNP's can be excluded from the display