Announcement

Collapse
No announcement yet.

Routing problem with grid 0.1mm

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Routing problem with grid 0.1mm

    Hi. I am going through the 'Altium Essentials' course and am using your final design after removing all routing, i.e. I am starting with your placement.

    When I route a track from a U1 pad and I stop the route in order to contemplate what to do next I am presented with two possibilities to go up or down on an angle but not straight ahead. It is as if the track is off-grid but it isn't.

    In your tutorial you set the grid to 0.1mm and there you don't seem to encounter this problem. With me I do encounter this problem.

    For me the only way to resolve this problem is to reduce the routing grid to 0.05mm. Then it is OK.

    I am at a loss to understand why I can't get the same effect for a 0.1mm grid.

    Here is a link to a small video illustrating the problem:
    ftp://tikun:[email protected]_090011.mp4


    Thanks for your help and your great courses!

    Michael

  • #2
    Well, it is not up or down. The end is a 45 degree track, and yes, that snaps to the grid.
    You could switch on "look ahead mode" (key 1) to only route the horizontal part first.

    Comment


    • #3
      Altium behaves a little bit differently between versions and also they keep changing some settings. I am not exactly sure which of the settings is this.

      But, I would not worry about this too much - you can just connect it to the +vin pad.

      Comment


      • #4
        The look ahead option is the one where the trace is places after the bend or only just before. When placing a a trace (at a 45 degree angle) press the 1 key.
        In the picture below, the left if with look ahead on, the right it is off. You can see it on the hashed line vs the blank one.

        Click image for larger version

Name:	Altium look ahead.png
Views:	40
Size:	17.3 KB
ID:	16469

        Comment

        Working...
        X