Announcement

Collapse
No announcement yet.

How to route traces without losing the sight of everything?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Solved] How to route traces without losing the sight of everything?

    Hi all
    When I try to route traces everything turns black except the initial and final pad. How can I see everything?
    Thanks
    Attached Files

  • #2
    This is some masking mode that is active when routing to help you to focus on what you're routing. Probably you have it set to maximum. You can increase/decrease the mask using [ and ] keys.

    Comment


    • #3
      What is the exact procedure to follow? in my keyboard I have to press altgr key and [ or ] to have [ or ]...

      Comment


      • #4
        So try it. Is it working?

        When routing you need to press this key to adjust the mask.

        Comment


        • #5
          It doesn't work. Somehow now it's not black as in the original post while I trace but I haven't understood why. If I start a trace and keeping pressed the left button ot the mouse I click altgr and [ or ] nothing changes as intensity.

          Comment


          • #6
            You should use it in the following way:
            1. Start routing - left mouse button click to start trace.
            2. Now release the LMB.
            3. And now you can adjust masking using [ or ].

            If it's not black then what? Can you show it?

            I found now that if you have troubles with this masking mode you can disable it. Go to Tools - Preferences - PCB Editor - Display. There uncheck "Apply Mask During Interactive Routing".

            Comment


            • #7
              I cannot vary the intensity of the shading.
              Fortunately right now I think it's acceptable. Even if I don't know how it turned from very dark to mild dark...
              Attached Files
              Last edited by Lucky-Luka; 02-17-2021, 04:07 AM.

              Comment


              • #8
                Finally I found where you can change it without using keyboard

                Go to View Configuration panel and View Options tab. In Mask and Dim Settings section you have a slider when you can adjust the masking. What interests you is Dimmed Objects setting.

                You can do it while routing (first press Tab to stop routing and now you can go to this panel) to preview the changes.

                Comment


                • #9
                  Thanks for the solution but I have finally found the right 2 keys!!! I have looked for them everywhere and I've found them.
                  ' and ì: the two keys above [ and ]!
                  Attached Files

                  Comment


                  • #10
                    Originally posted by przemek View Post
                    Finally I found where you can change it without using keyboard

                    Go to View Configuration panel and View Options tab. In Mask and Dim Settings section you have a slider when you can adjust the masking. What interests you is Dimmed Objects setting.

                    You can do it while routing (first press Tab to stop routing and now you can go to this panel) to preview the changes.

                    I was recently messing with this. A good way to get a handle on these controls is to use the PCB panel in nets mode. If you click on a net name, Altium wants to show you that net, and you can select whether the method to show you involves masking or dimming or whatever at the top of the PCB panel. Then you can use the controls that przemek mentions to tune how it works. Not as easily adapted to an unrouted design, but I imagine you'll get the picture. Also, surprisingly, Altium has a pretty good help section explaining these controls too.

                    Comment

                    Working...
                    X