Announcement

Collapse
No announcement yet.

PCB Rules can't be changed

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • PCB Rules can't be changed

    Hi. I am using the V1I1 project in your Aurduino course. The problem is this:
    • I open the project in altium 21.1 OK.
    • I redefined the WIDTH in Design/Rules to be 0.3mm per the course.
    • I open the PCB and select the top layer.
    • I delete one of the tracks to play with drawing my own track.
    • I draw a track and press spacebar
    • The widths available to me are 0.15mm for all three and not the 0.3mm that I defined.
    I have done everything to get the PCB to accept the updated design rule but to no avail.

    What I did do to get something is as follows:
    • Create new PCB
    • copy/paste entire layout from existing PCB to the new one.
    • Now the new one
    • accepts the updated design rule
    Obviously this is not acceptable.

    How can I fix this?

    How can make Altium revert to default configuration. I ask this because in your design Altium attempts to refer to an integrated library of yours that doesn't exist.

    BR

  • #2
    What if you right-click on the trace and select "applicable unary rules"? Width should be one of them.

    Comment


    • #3
      Keep in mind that there are two parts to getting design rules to work. You have the design rules and the design rule checker. The checker controls which rules are enforced and how they're enforced. Look to Tools>Design rule check>rules to check. Confirm that the rules are actually being enforced. Online means that rule is continually being enforced as you work. Batch means it's checked when you run the checker.

      Comment


      • #4
        Double check system preferences - you can change the behavior there:

        Click image for larger version

Name:	image_3725.png
Views:	44
Size:	83.2 KB
ID:	17505

        Comment


        • #5
          I did all those things. No change. The PCB design remains loyal to 0.15mm widths it obtained prior and nothing I do changes it. To get it to work I need to create a new PCB and copy the prev to it. This, of course, is less desiraable. I also tried to export/import design rules, again no potatoes.

          Comment


          • #6
            What if you right-click on the trace and select "applicable unary rules"? Width should be one of them.

            The following images shows:
            1) Unary rule is 0.3mm
            2) Preferences show "User preferred rule"
            3) When drawing a track the selected width is 0.15mm


            Click image for larger version

Name:	altA-1.jpg
Views:	39
Size:	72.7 KB
ID:	17541

            Click image for larger version

Name:	altA-2.jpg
Views:	34
Size:	104.7 KB
ID:	17542


            Click image for larger version

Name:	altA-3.jpg
Views:	28
Size:	209.6 KB
ID:	17543

            Comment


            • #7
              Puzzling.
              What does it state in the netlist editor?
              What do you get in the properties panel when you start routing (rules section)?
              Click image for larger version

Name:	Capture width.PNG
Views:	30
Size:	67.9 KB
ID:	17549

              Comment


              • #8
                mstamler it just should work. Do you have latest Altium updates?

                BTW: Often I manually write the numbers when I route, I do not use any special presets for track width. Did you try to rewrite the value?

                Comment

                Working...
                X