Announcement

Collapse
No announcement yet.

The BOM template has been replaced -Altium 20.2

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • The BOM template has been replaced -Altium 20.2

    Hello all,
    When I export the BOM file using my BOM template, I uncheck all of the choices listed below.
    But I'm not sure why the BOM template was replaced after I exported.
    Click image for larger version

Name:	BOMs problem.png
Views:	60
Size:	110.7 KB
ID:	18460


    If there is a missing step or if my settings are incorrect, please advise on how to correct it.

    I hope everyone understands; I'm new to Altium and English isn't my first language.
    Thank you so much for taking the time to read this. Any response would be beneficial.

  • #2
    Please, could you be more specific, how was it replaced? The template in your screenshot says: "No Template".

    Comment


    • #3
      Hi sir,
      The template in my screenshot says: "No Template". It's an issue, and I'm not sure if others are experiencing the same difficulties as me. Even if Altium has gotten the template, it will show No template or nothing.
      This is my Bom Template
      Click image for larger version  Name:	original_template.png Views:	4 Size:	113.5 KB ID:	18471
      And when I export the BOM. The file BOM is successfully exported, however the BOM template has changed to file BOM. It means I won't be able to use the BOM template again in the future.
      BOM
      Click image for larger versionName:	BOM_Export.pngViews:	3Size:	151.3 KBID:	18472BOM template
      Click image for larger versionName:	template_is_overwritten.pngViews:	3Size:	151.3 KBID:	18473I tried the "Relative Path to Template File" option, but nothing changes or happens. Could you kindly clarify what the "Relative Path to Template File" option means?
      Click image for larger version  Name:	Relative_Path.png Views:	3 Size:	11.4 KB ID:	18474

      I fixed the problem by changing the local path. I think folder path project relative to OneDrive is the problem, although I chose "Always keep this device".
      Click image for larger version  Name:	folder_path.png Views:	4 Size:	110.8 KB ID:	18475

      Thank you for your response, Sir. It was really useful to me.
      Attached Files
      Last edited by Linh Tran; 10-18-2021, 11:36 PM.

      Comment


      • #4
        A template should be a .xlsTfile. If you just use xlsX it is not not fault of Altium that your template is replaced, but Excel's fault.
        Use File / Save-as and select Excel Template to save it as template.
        I may be mistaken on the Excel part as I do not use Excel myself.

        Comment

        Working...
        X