Announcement

Collapse
No announcement yet.

Unrouted Nets and Net Antennae Errors

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Unrouted Nets and Net Antennae Errors

    Hello,

    I am getting Unrouted Nets and Net Antennae error after routing my PCB and doing a design rule check. Below screenshot will give you a better idea on what my errors are. I am stuck here please help me out I tried everything but nothing takes the error off. I even assigned net name to the power plane. Even after that it show my power plane layers have not nets connected to them.
    Attached Files
    Last edited by Haiderabidi444; 04-11-2022, 03:04 PM.

  • #2
    Did you assign nets to the planes?

    This usually happen for example if you have a plane layer, but you don't specify the net where it is connected. For example, go to layer 2, double click on the plane and be sure it is connected to GND.

    Comment


    • Haiderabidi444
      Haiderabidi444 commented
      Editing a comment
      Yes I assisgned net name to plane but still it doesnt seem to take it. Is there any different way other than double clicking the layer and giving it a net name instead. You can see in my screenshot named fd3. Instead of split planes I get properties menu popup. And another thing that I noticed was I cant even place polygon pour on these layers.
      Last edited by Haiderabidi444; 04-11-2022, 06:30 PM.

  • #3
    Perhaps to see what's wrong, you can switch to 3D view and set the PCB thickness setting to some extreme. This has the effect of spacing out all of the layers. You should be able to drive around and view how L5 is constructed. Otherwise, you could temporarily output gerbers and then view the gerbers in Camtastic. Non ground vias that go through L5 should have a space around them so L5 plane doesn't connect to it. Vias that are supposed to be ground should appear attached to the L5 plane.
    Now that I think of it. Check in Design>Rules There should be a rule for power plane connect style. Typically vias connect to plane layers by direct connection, or by spokes, but I think your choices are Direct, spokes, or no-connect. Perhaps if the rule is missing, or it is there but set wrong, there is no connection allowed at all? Seems vaguely familiar. Maybe I ran into something similar a few years ago

    Comment


    • Haiderabidi444
      Haiderabidi444 commented
      Editing a comment
      I just see direct, relief and no connect option only. i changed all of them but no luck. And another thing that I noticed was I cant even place polygon pour on these layers.
      Last edited by Haiderabidi444; 04-11-2022, 06:30 PM.

  • #4
    Double click on the plane itself, not the name.

    Comment


    • Haiderabidi444
      Haiderabidi444 commented
      Editing a comment
      Double clicking on the plane is not giving me the pop up window for split planes. I dont know why its doing that.

  • #5
    Did you select the layer first?

    Comment


    • #6
      Haiderabidi444 This may happen due to enabling unconnected pins in rules or you may enabled incomplete connection check in unrouted rules.

      If you uncheck the option, it may go.
      But the main reason for this error if tracks were not routing from center of pads origin this error will come. Eventhough, Tracks is barely touched the Component Pad, Routing is practically connected. But if you checked the incomplete connection option, altium completes routing of any net only it is traced out from exact center of the pad origin you may see that in picture also. Please try that.,..

      Click image for larger version

Name:	jig.png
Views:	69
Size:	12.9 KB
ID:	19581

      Comment


      • #7
        Double clicking on the plane is not giving me the pop up window for split planes. I dont know why its doing that.
        How did you create the split planes?

        Comment

        Working...
        X