Announcement

Collapse
No announcement yet.

Coplanar Waveguide - Gnd Polygon to Track width Clearance

Collapse
This topic has been answered.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Coplanar Waveguide - Gnd Polygon to Track width Clearance

    Hi All,

    I have to set the Gnd Polygon to Impedance track clearance as 5.8mil for Coplanar Waveguide Impedance Matching. But alitum is not picking that clearance. Please guide me?
    Thanks!!

    Click image for larger version

Name:	2.png
Views:	47
Size:	46.2 KB
ID:	19966 Click image for larger version

Name:	1.png
Views:	37
Size:	101.4 KB
ID:	19967
  • Answer selected by Lakshamana Balakrishnan at 06-15-2022, 09:38 PM.

    Originally posted by Lakshamana Balakrishnan View Post
    I have measured the above value from Primitives Measurement only.
    What if you just measure distance?
    Optionally press Ctrl while clicking the points.

    Then again, I have a rule set to 0.2mm and have 0.209mm clearance between via+track and polygon. Perhaps polygons have additional clearance just because they are a bit less accurate (rounding errors). See picture here where you see a nice round via (bright red, left) and a jagged polygon. The lower distance is to the straight part, the upper distance to one of the inward point.

    Your distance 6.2mil (0.15748mm) and 6.537mil (0.1660398mm) has a difference of 0.337mil (0.0085598mm). In this capture I have 0.007mm
    Click image for larger version  Name:	Capture polygon clearance.png Views:	0 Size:	7.7 KB ID:	19995

    But I think I have found your solution - decrease the arc approximation. Default is 0.013mm (0.0003302mil?), now when I set it to 0.002mm (0.0000508mil)
    Click image for larger version  Name:	Capture polygon arc approx.png Views:	0 Size:	25.2 KB ID:	19996
    Both the arc is much smoother and the clearance smaller.
    Click image for larger version  Name:	Capture polygon clearance fine arc.png Views:	0 Size:	6.5 KB ID:	19997

    And we have about the settings of the rule.

    Comment


    • #2
      to measure clearance, use Report -> Measure primitives. Then select the polygon, select the track and that will give you the correct measurement.

      Comment


      • #3
        And make sure the rule is enable too!

        Comment


        • #4
          robertferanec, By measuring air gap also i am getting different clearance of what i set in altium.

          qdrives rules were enabled,

          What may be the reason??

          Comment


          • #5
            Does it matter if the clearance is only towards polygons? If not, change the rule from InPolygon to All.
            The table below allows you to set different clearances for different objects, like polygons (advanced).
            I am also wondering if InPolygon is correct for this.

            Comment


            • #6
              Also, don't forget that the rule needs to be enabled, and checking the rule needs to be enabled (real time VS batch), and you may have to repour the polygon(s) to get them to obey the rules

              Comment


              • #7
                Hi All,

                I am happy to hear your different suggestions.

                Actually copper to track Clearance is getting adjusted based on my value which i set in clearance rule. No problem in Rules settings and it is enabled well. I have tested rules setting in testqueries which detects their primitives exactly too.

                But the main problem is If I set 5.8mil clearance in rules tab it gets 6.129mil air gap in acutal layout.

                and If I set 6.2mil it gets 6.537mil air gap

                I have measured the above value from Primitives Measurement only. Please kindly provide any suggestions.

                Thanks in Advance!!.

                Comment


                • #8
                  Originally posted by Lakshamana Balakrishnan View Post
                  I have measured the above value from Primitives Measurement only.
                  What if you just measure distance?
                  Optionally press Ctrl while clicking the points.

                  Then again, I have a rule set to 0.2mm and have 0.209mm clearance between via+track and polygon. Perhaps polygons have additional clearance just because they are a bit less accurate (rounding errors). See picture here where you see a nice round via (bright red, left) and a jagged polygon. The lower distance is to the straight part, the upper distance to one of the inward point.

                  Your distance 6.2mil (0.15748mm) and 6.537mil (0.1660398mm) has a difference of 0.337mil (0.0085598mm). In this capture I have 0.007mm
                  Click image for larger version  Name:	Capture polygon clearance.png Views:	0 Size:	7.7 KB ID:	19995

                  But I think I have found your solution - decrease the arc approximation. Default is 0.013mm (0.0003302mil?), now when I set it to 0.002mm (0.0000508mil)
                  Click image for larger version  Name:	Capture polygon arc approx.png Views:	0 Size:	25.2 KB ID:	19996
                  Both the arc is much smoother and the clearance smaller.
                  Click image for larger version  Name:	Capture polygon clearance fine arc.png Views:	0 Size:	6.5 KB ID:	19997

                  And we have about the settings of the rule.

                  Comment


                  • #9
                    Yeah qdrives , You are exactly, Correct. It worked too. I have set the arc approximation to 0 mil by entering 0.0001 mil which automatically eliminated that error. This arc approximation has impact on clearance rules well.

                    Thank you so much for your help.

                    Comment

                    Working...
                    X