Announcement

Collapse
No announcement yet.

Nets not assigned to lines.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Nets not assigned to lines.

    I'm sorry if this is a dumb question. All of a sudden, when I draw a track/line in the PCB editor of Altium Designer, the nets are no longer assigned to those lines. I've checked to make sure I'm on the correct layer etc. To assign nets now, I have to manually select the correct net or use the dropper tool. Iv've not changed any settings or anything that I am aware of.

    Can somebody point me in the right direction to fix this please?

  • #2
    Are you starting drawing the tracks from pads and have these pads a net assigned?

    Comment


    • #3
      You may have accidentally cleared the netlist of your PCB. Try updating the PCB's netlist from your schematic. Go to your schematic, then Design / Update PCB Document .....

      Comment


      • #4
        Thank you Robert & Ronny for your suggestions.

        I have started drawing the track from the pad and to the pad. Also I've followed your suggestion Ronny.

        Below on the GND track, you can see that both pads are assigned to GND but the track doesn't "take" the assignment of GND.

        I'm not sure if this sheds light on this or not, but I have used the Snap EDA plugin to automatically download the component schematic and footprint etc. The issue isn't just on this one component so that makes me think I've done something common to all components.

        I hope this makes sense.

        Click image for larger version

Name:	Screenshot 2022-07-12 191023.png
Views:	28
Size:	54.7 KB
ID:	20271

        Comment


        • #5
          So I tried this in the PCB design. Design > Netlist > Update Free Primitives From Component Pads.

          This fixed the issue with tracks that I have already drawn such as the GND in the above image, but new tracks still don't automatically get assigned.

          Below, you can see the GND is assigned but the +5V (a new track) hasn't been.

          Click image for larger version

Name:	Screenshot 2022-07-20 200215.png
Views:	23
Size:	119.0 KB
ID:	20274
          Attached Files

          Comment


          • #6
            Even more curious, a no-net track on a net-assigned pad should violate default rules.

            Perhaps look at tools>design rule check>rules to check, and confirm at least some basic rules are enabled in the online column.

            Perhaps try creating your own simple component and add that to the design a couple times to see if those route normally.

            If you start a track on a pad and stop, then run the design rule checker, is the track marked with a net antenna drc error?

            If you manually assign the net to the existing track, then continue routing it, does the additional track have the assigned net or is it no-net?

            Comment


            • #7
              Restore to the default settings.
              Tools / Preferences.

              Save all settings just to be sure.
              Click set to defaults -> Default (all).

              Clean the netlist. This has helped me once with another strange issue (zooming wrong).
              Design / NetList / Clean all nets.
              Just to be clear, I am talking about cleaN not cleaR.

              Click image for larger version

Name:	image.png
Views:	36
Size:	76.8 KB
ID:	20277

              Comment


              • #8
                I get a similar behavior if I try to route traces using the "Line" tool. Are you using the "Interactively Route Connections"?

                Click image for larger version

Name:	image.png
Views:	27
Size:	13.1 KB
ID:	20280

                Comment


                • #9
                  Hi all,
                  Thank you very much for all of your input and help.

                  What I did to "fix" this was:

                  1: Reset all defaults (this didn't fix it though)
                  2: Deleted the PCB design
                  3: Update Altium to the latest version
                  4: Reset all defaults (just in case)
                  5: Start the PCB design again.

                  I'm lost as to why this would have happened, but all looks to be good now.

                  So now the tracks show and are linked to the nets perfectly.

                  Again, Thank you.

                  Comment

                  Working...
                  X