Announcement

Collapse
No announcement yet.

What stops Altium from enforcing board outline clearance? (version 22.7.1)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • What stops Altium from enforcing board outline clearance? (version 22.7.1)

    Hi All,

    I've got a single simple board outline clearance rule, it's enabled in rules. In the rules to check list, checking it is enabled for both online and batch, but son of a batch, it's not working.

    ¯\_(ツ)_/¯

    Usually, I get an "out of board" violation marker on components, and I usually can't shove traces off the edge of the board. But this isn't working as you can see from the image below:
    Click image for larger version  Name:	2022-08-27_09-48-21.png Views:	0 Size:	11.2 KB ID:	20456

    This is the rule I have enabled:
    Click image for larger version  Name:	2022-08-27_09-51-52.png Views:	0 Size:	36.2 KB ID:	20457

    Here is where I have checking it enabled:
    Click image for larger version  Name:	2022-08-27_09-52-49.png Views:	0 Size:	67.8 KB ID:	20458

    Any thoughts? Thanks!

  • #2
    Update: When I run the rules check, the out of board violations appear in the messages panel. So, Altium is finding the rule violations, it just doesn't mark them or in the case of routing, it doesn't enforce them. That is, Altium shouldn't let me shove routes off the board and Altium should fully fill out polygon pours that go off the board. Polygon pour filling should stop at the PCB edge.

    Comment


    • #3
      Update: After posting this here, I also posted to Altium support. Then I wanted to draw a polygon pour that straddles the PCB edge to better illustrate what the issue is, and enforcement started working again. I moved the trace that was hanging off the edge of the PCB and it whipped right into shape against the edge of the PCB. I drew a polygon pour and it filled out to the edge of the PCB and no farther.

      Still, out of board violations aren't marked as out of board per usual. Very strange.

      Comment


      • #4
        When I have problems with rules, sometimes "Run Design Rule Check" will help.

        Did you try to go through Panel -> PCB Rules and Violations? https://youtu.be/f7GP6NZs0Ok?t=1890

        Comment


        • #5
          What is the setting you have for conflict resolution?
          Click image for larger version  Name:	Capture conflict resolution.png Views:	0 Size:	40.0 KB ID:	20474
          If I have it at Ignore obstacles it will route outside the board.
          With the other settings it does not.

          And just to make sure: the rule itself is also enabled?

          Comment


          • #6
            Thanks, robertferanec and qdrives I will check

            Comment

            Working...
            X