Announcement

Collapse
No announcement yet.

Component Rotation and Clearance

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Component Rotation and Clearance

    Hi all,

    I never tried to place a component at 45 degrees angle before but when I tried this I face an issue.

    when the component is set to a 0-degree rotation angle it follows the clearance rule define in the "Component clearance rule" but when I rotate the component at 45 degrees it does not follow the clearance rule I am unable to put components closer to each other I am using Altium17.1 what setting I required to change or I have to define new rule?

    any help will be appreciated thankyou.
    Last edited by Manpreet Singh; 09-01-2022, 10:24 PM.

  • #2
    It should work. Try to switch on all layers and have a look what the white square is around.

    Click image for larger version

Name:	45 deg.png
Views:	33
Size:	432.8 KB
ID:	20510

    Comment


    • #3
      1) Do you have a 3D body with the footprint?
      2) What rule setting do you have for the component clearance?

      You might try the option "Check clearance by component bundary".
      Click image for larger version

Name:	Capture component clearance.png
Views:	24
Size:	66.7 KB
ID:	20515

      Comment


      • #4
        Notice the highlight difference between Manpreet Singh and robertferanec . With the first the square around the component is 'horizontal'. With the screenshot of Robert, the highlight has rotated with the component. First one probably does not have a 3D body whereas the second does.

        There also was something about this with either a newer version of Altium or added setting, but I cannot remember the details of where I had seen it.

        Comment

        Working...
        X