No announcement yet.

Component clearance DRC

  • Time
  • Show
Clear All
new posts

  • Component clearance DRC

    Hello. I have a problem with component clearance checking in DRC. This rule is not checked, but it is enabled. Altium allows me to place the components to close, because I use the placement mode "MOVING(Push:Ignore)". Then, when I run DRC, if two components are too close, the DRC does not show any error. However, the rest of errors are cheked. I have attached a pdf file with screenshots and a brief description of the problem. Thank you in advance for your help.
    Attached Files

  • #2
    I experience the same behaviour. The online DRC doesn't seem to be working correctly in this case. When you run a manual DRC though, it catches the error. So it is not a huge problem. With more complex designs you don't use the online DRC anyway, since it slows down the performance.

    BTW very good representation of the problem


    • #3
      Hello. Thank you Mairomaster for your help. I think you have not understand all the problems. When I run manually DRC, Altium does not detect the error. It doesn´t show that the distance between the two components is too small. As you can see, the outline of the two components are superposed, however, the DRC report does not show any violation of this rule. What could be happening? Thanks again!!


      • #4
        Hmm I don't know why is that. Your setup seems right to me. What version of Altium are you using? Just to be sure, is the same happening if you completely overlap the components, including the pads? Do you have 3D models in your components? That is not completely relevant in this case, but keep in mind that if you have 3D models, altium measures the minimum distance between them. If you don't have 3D models, Altium should be considering the selection rectangle of the component I believe.

        As I said, I don't have such problem with the manual DRC, just with the online one.


        • #5
          Hello. Yes, I have 3D models in all the components, but if I choose "MOVING(Push:Avoid)", Altium does not let me to place the components if there is not a gap of 0.1mm (the gap I have defined as the minimum gap between components) between the component outlines (the silkscreen), so the 3D model should not be the problem... I use Altim 16.0.8.


          • #6
            I noticed the same as mairomaster mentioned - if you use 3D model, I think, the component clearance is done based on them. I do not use "MOVING (PUSH:Avoid)" for component placement, so I am not sure about the behavior. Maybe try to disable Silk-To-Silk rule, just to be sure the PUSH Placement doesn't take into consideration also the Silkscreen rule.