Announcement

Collapse
No announcement yet.

Moving a component that has already been placed on the board.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Moving a component that has already been placed on the board.

    Hello,

    Once I have placed a component on the board I can not move it again until I select it in the schematic and click in the PCB window and select "Replace selected component" command. In you videos, you just click on a component and you can move it. How can I do this?

    Thank you,
    Steve

  • #2
    Maybe the components are locked? Try to double click on it and uncheck "Locked"

    Click image for larger version

Name:	locked component.png
Views:	1043
Size:	303.9 KB
ID:	452

    Comment


    • #3
      Hello Robert,

      The components were locked but after unlocking them I still cannot simply right click on a component in on the PCB and move it. I still have to select it in the schematic, click in the PCB window and press the "Reposition Selected Component" command every time I need to move a component. Is there something else I might be missing?

      Thank you,
      Steve

      Comment


      • #4
        Try left mouse button - move your cursor above component, press left button, hold it down and drag.

        Comment


        • #5
          Robert,

          I meant to say left click. If I hold down the left mouse button and try to drag it just created a selection window but nothing gets selected.

          Comment


          • #6
            If the component is unlocked and it doesn't work, try to close Altium and start it again. It just should work.

            Comment


            • #7
              Robert,

              Thank you. That did it.

              Comment


              • #8
                Perfect

                Comment


                • #9
                  Hi gents,
                  I have similar prolem with Altium 18, during the Course 3 and Lesson 1, of advanced PCB design. More specifically right after the "reposition selected components" the PCB area freezes and cannot move or select any component , not only those that are just placed. The components are not locked. I can continue though "repositioning" more components but cannot move any of them as single componenent.

                  The problem is fixed only after AD18 restart.

                  Even though you can work somehow, it is very annoying.

                  Do you know why this is happenning, or anybody with similar experience?

                  Appreciate your responses.



                  George

                  P.S. : I think while not still sure, that this happened after I installed the AD18 while keeping AD16 in the system. Then I cleaned (fully) and reinstalled the AD18 but the issue remains. I don't remember having this issue with AD16 before installing the AD18.

                  Comment


                  • #10
                    Try to click on the Clear button in PCB panel - maybe the components are somehow filtered.

                    Click image for larger version

Name:	clear button.jpg
Views:	1060
Size:	20.0 KB
ID:	10534

                    Comment


                    • #11
                      Hi Robert,
                      That really solves the issue. Thanks!!!
                      For some reason the components are somehow filtered but quite strangely only after every reposition action.
                      But ok, by this "clear" action everything is fine.

                      Thanks a lot for the tip !

                      Best regards,
                      George

                      Comment

                      Working...
                      X