Announcement

Collapse
No announcement yet.

Generating Bill of materials

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Generating Bill of materials

    Hello everybody !

    ​I have a PCB project.
    I added a few fields in the schematic library (ie width, length, height).when it doesn't exist.
    For each component I filled these fields with the right information according the datasheet.
    Example:

    Height = 1.20 mm

    I would like to generate the BOM including these information.
    When I enter the BOM setup page, I can't see the information I filled in.
    For sure I didn't forget to check width, length and height.
    I only see the information given by the supplier when it exists.
    How can I proceed ?

    Thank you.

  • #2
    Important information: I also added the parameter "Weight" to each component in the schematic library.. It doesn't appear in "All columns" of the bill material page setup.

    Comment


    • #3
      You should be able to see the parameters in the left panel of BOM job file, you need to find them there and Check it. Have a look at the attached screenshot (example of .Checked PCB - this is my own custom parameter):


      Click image for larger version

Name:	bom parameters.png
Views:	46
Size:	96.1 KB
ID:	5017

      Comment


      • #4
        Thanks for reply !
        Do you see any reason why my custom parameter doesn't appear in All Columns ?

        Comment


        • #5
          Could you post screenshot of the window where you created this parameter?

          Comment


          • #6
            I added Height, Length, Width and Weight for each component in the window attached (Library Components Properties).
            ​I took the example of the component LP2985 ... because information about Height, Length and Width doesn't appear as you can see in the BOM page setup (screenshot).
            Weight is not present in "All Columns".
            You can notice that I get the information "No PCB Document selected).

            Comment


            • #7
              Did you save possibly compiled the library?

              Comment


              • #8
                What do you mean ?

                Comment


                • #9
                  - I mean, if you did not forget to Save and then Compile the library. Sometimes happen, that if you do some changes in library, people do not save the library or they forget to recompile the library and then the changes are not visible.

                  - Also double click on the "wrong" components in your schematic and check if the parameters are filled out there - if not, you need to synchronize your library with the components in your schematic.

                  Comment


                  • #10
                    I only compile the project. I'll check. Thank you again !

                    Comment


                    • #11
                      Effectively when I double click onto the component LP2985 in the schematics the parameters I added do not show up. How can I synchronize the schematics library with the schematics ? I didn't find where it is.

                      Comment


                      • #12
                        There are more ways, you can do for example right click in your schematic library on the specific component and select "Update Schematic Sheets"

                        Click image for larger version

Name:	sychronize schematic with library.png
Views:	58
Size:	110.5 KB
ID:	5035

                        Comment


                        • #13
                          When I update Schematic Sheet it perfectly runs : I have got the parameters in the BOM page setup.
                          Thank you !

                          Comment


                          • #14
                            perfect

                            Comment

                            Working...
                            X