Announcement

Collapse
No announcement yet.

Differential Pairs Uncoupled Length

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Andrius
    replied
    Thanks, maybe just Altium version is too old

    Leave a comment:


  • robertferanec
    replied
    I don't think it's really uncoupled. In my opinion, when you draw a corner, Altium may not be able to draw the lines precisely in the exact space between them (because of grid or something) and the space may be a little bit different (a very small number different), but Altium may recognize it as out of tolerance. At least, that's what I think. I noticed, that in the latest Altium it's working oki.

    Leave a comment:


  • mairomaster
    replied
    Part of the problem might be due to using a very old version of Altium. Lots of things have been improved over the years. I definitely recommend moving to a newer version if possible.

    Leave a comment:


  • Andrius
    replied
    Yes, the corners are uncoupled and adding tolerance helps, but the biggest problem is that almost all thack length (as shown in the picture) is uncoupled according to altium..

    Leave a comment:


  • robertferanec
    replied
    In some Altium versions, some corners are marked as "uncoupled". Try to add a little bit of tolerance (min / max) into the rules and let me know if it helped.

    Leave a comment:


  • Andrius
    replied
    Hello, I have the opposite problem - even if the pairs are exactly 0.3mm apart, as set in the rules, DRC checking shows error - that these pair are uncoupled. What could be wrong here? Using Altium Summer 09 I attach screenshots
    Attached Files

    Leave a comment:


  • robertferanec
    replied
    Perfect. I am very happy it works now

    Leave a comment:


  • mairomaster
    replied
    Awesome! That was the problem indeed. The confusing part was that everything in the differential rules apart from the uncoupled length part seemed to work fine. But when you use differential pair classes instead of normal classes, the uncoupled length works as well.

    Thanks a lot!

    Leave a comment:


  • robertferanec
    replied
    That is the problem You need to use Differential pair class for Differential pair rules.

    Leave a comment:


  • mairomaster
    replied
    Thanks for the advice Robert! I should have though about that myself, I always use the Rex board as a reference for all kinds of things.

    I tried the rule and it works perfectly fine with the Rex board. Something should be wrong with my project I guess, but I still can't figure out what. I definitely have the signals as differential pairs - the only difference I can tell is that you are using differential pair classes and I am not, but that should not be the problem I think.

    Leave a comment:


  • robertferanec
    replied
    Hmm, seems to me ok.

    Possibly, you can try to check PCB from our iMX6 Rex project. Download the Altium files and have a look. To test it, you can change the MAX uncoupled length to 0mm.

    Here is the link to the project: http://www.imx6rex.com/

    You will need to register and then Click here to Download iMX6 Rex Module Project >

    Leave a comment:


  • mairomaster
    replied
    Here is the screenshot.

    Leave a comment:


  • robertferanec
    replied
    mairomaster please, could you post a screenshot of your Differential pair rule settings (Design -> Rules -> Design Rules -> Differential Pairs Routing -> Your Rule)?

    Leave a comment:


  • mairomaster
    replied
    Yes Robert, I tried this but still no result. I also tried with 2 different versions of Altium - 15 and 16 (last updates on both). Thanks for the suggestion though.

    Leave a comment:


  • robertferanec
    replied
    Hi Miroslav,

    did you try to set DRC Violation Display to "Always" and check "Differential pair routing" (DXP -> Preferences -> PCB Editor -> DRC Violation Display)?


    Click image for larger version

Name:	DRC Violations Display.jpg
Views:	1492
Size:	150.3 KB
ID:	701

    Leave a comment:

Working...
X