Announcement

Collapse
No announcement yet.

Schem pin designator locations wrong in pdf, but right in schem. Help!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Schem pin designator locations wrong in pdf, but right in schem. Help!

    Hi, thanks for your help. I've got a really weird behavior (AD16) that I haven't seen before. In the schematic editor my pin designator locations are fine and look like they're supposed, but then when I export a schematic pdf the pin designators on the left side move over to the left for some reason, and the right ones stay put. The problem is that they're overlapping the net labels and are unreadable. Here are pics of the schematic editor (how it should be in the pdf output):
    https://imgur.com/6ZAK4cW

    And the pdf output (incorrect style):
    https://imgur.com/tivWEwm

    Any idea why this only happens during the pdf export? What settings do I need to change to fix it? I've looked all around and can't figure out why this is happening during the pdf export. Thanks!

  • #2
    I have seen similar post on this forum. I am not sure how it was solved. Please, what PDF Creator are you using? Some people told me, that Foxit PDF creator works better than PDF forge Creator. Which one are you using? Or are you using the build in Altium PDF Creator?

    Comment


    • #3
      Robert, thanks for your response! Yes, I'm using the built-in Altium pdf generator through my output job file:

      https://imgur.com/ZGEwalC

      Is there a way to change that to a different pdf generator? Like Adobe or Foxit or something? It does seem like some kind of misbehavior related to the pdf conversion process.

      Thanks!

      Brian

      Comment


      • #4
        When you install a PDF creator, you can add it into outputs:


        Click image for larger version

Name:	altium print outputs.jpg
Views:	108
Size:	75.7 KB
ID:	7244

        Comment


        • #5
          Robert, thanks again for your input, but I just tried that and it's still not working. In fact, I tried it with just a normal printer and it's still putting the pin designator/numbers on the far left during printing from my normal printer. See this pic of the left side numbers being way over to the left still, whereas the right is just fine.

          https://imgur.com/0P6FUaX

          So it appears that it's not related to going to PDF, but just exporting in general (both with pdf and printing). Any other ideas? Does this happen with you at all? I'm using AD16, fyi.

          Thanks,

          Brian

          Comment


          • #6
            Brian, I have not experienced this problem (or I have not noticed that). I am not really sure what to do. Normally I would:
            - install latest fixes for that specific Altium version
            - maybe I would install the latest Altium version (?)
            - but most likely I would just go to the previous version of Altium where everything worked.

            I would not probably try to find a way how to fix it - unless it prints wrong way in all Altium versions (that would probably mean, problem is not Altium, but something on my computer). If it would not work only in one particular Altium version, I would just consider it to be a bug .... and I would not spend more time trying to fix it. I would just try to find a solution how to print it so it looks ok. It is not unusual, that we generate some outputs from particular Altium versions - e.g. assembly drawings (we often use AD14 for this).

            Comment


            • #7
              Yep, great advice, thanks!

              Comment


              • #8
                Brian, just in case you find a solution, please let me know. As I said, you are not the first one asking, so maybe it could help also other people too.

                Comment


                • #9
                  I definitely will share it here if I find a solution. I think it's probably a bug in Altium related to their export/print features, but I'm not upgrading my Altium version yet and so I can't say for sure. Thanks again! And Merry Christmas!

                  Comment


                  • #10
                    Merry Christmas and happy holidays

                    Comment


                    • #11
                      Hi,

                      I was asking also on this forum regarding this problem, about 2 months ago. Today I have posted on Altium's forum, and I got the solution which worked for me. It seems that it is a problem with a recent update from W10. Hence please go to : DXP->Preferences->Schematic->General->Render Text with GDI+ and uncheck Renfer Text with GDI+.

                      I hope works for you.

                      Best,
                      Mihai
                      Last edited by Mihai; 02-20-2018, 10:47 AM.

                      Comment


                      • #12
                        Mihai thank you so much for sharing this!

                        Comment

                        Working...
                        X