Announcement

Collapse
No announcement yet.

no grid units in schematic library editor- how ?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • no grid units in schematic library editor- how ?

    Hi,
    I have mm units on my schematic library editor, which makes my components unable snap to wires (and to each other) on my schematic.
    on my previous projects the grids on the schematic library editor were (and are) unitless.
    how can i change to unitless (relative?) grids ?

    screenshots:

    Click image for larger version

Name:	a.PNG
Views:	143
Size:	35.9 KB
ID:	9326
    Click image for larger version

Name:	b.PNG
Views:	115
Size:	31.0 KB
ID:	9327

  • #2
    i found it,
    the solution is to change to "Dxp defaults" under Schematic library options:
    Click image for larger version

Name:	c.PNG
Views:	106
Size:	19.3 KB
ID:	9329

    Comment


    • #3
      As a side note, I really don't recommend using metric units for schematics in Altium. I've never seen a schematic library for Altium done in metric. It's not that it doesn't exist, it's probably just super rare. And in this industry it's really good to stick to standards.

      Comment


      • #4
        Absolutely agree with mairomaster, just keep defaults for schematic and schematic libraries. If units are changed, you can have problems with compatibility with other libraries or reference designs - basically if you change the units, you may need to re-do many symbols which otherwise you could simply copy and paste into your library or schematic.

        Comment

        Working...
        X