Announcement

Collapse
No announcement yet.

Could Not Launch Footprint

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Could Not Launch Footprint

    Hi Robert,

    I downloaded a part from Ultra Librarian and put the OLB file and the DRA file in a local folder. But after I put the part in a schematic, this is a warning.
    WARNING(ORCAP-2434): Footprint 'CP_32_15' specified in PCB Footprint for instance 'U1' is missing. Ensure 'CP_32_15' is in the library path.
    What is the default location for OrCAD capture to search for the footprint associated to a symbol? Can I change or add the path to let OrCAD capture know the right location of the footprint?

    Bruce

  • #2
    This may help:
    http://esdresources.blogspot.com/201...cadence_4.html

    Points 2 and 4 are interesting:
    2. Launch Design Entry CIS. Note the full path for the Capture.ini file shown on the Start Page (see Figure 2). Depending on how Cadence is installed on your computer, the full path should be similar to:

    C:\Cadence\SPB_Data-Silent\cdssetup\OrCAD_Capture\17.2.0\Capture.ini

    or, if you made a custom HOME variable:
    %HOME%\cdssetup\OrCAD_Capture\17.2.0\Capture.ini


    4. The Capture.ini file will open in Notepad. Under the [Allegro Footprints] section, add the full library search path from step 1 above if it is not already listed (see Figure 4). Note that you must increment the number after Dir for each path added (e.g., Dir0, Dir1, Dir2). Do not delete any existing paths from the list.

    Comment


    • #3
      It works after I added the path to the [Part Library Directories] section.

      It looks like there is an easy way to do this. From PCB editor a path can be added from Setup->User Preferences->Paths->Library. I'll try this way later.

      Comment


      • #4
        Hi robertferanec ,

        Here is a summary of my problem so far (I have followed everything until Lesson #4 Learn Orcad and Allegro Essentials) -

        I created the PAD file "smd_w0mm95_h1mm35" using Padstack Editor in two directories
        A - C:\Users\vinaygh\Downloads\OrCAD Lessons (where my actual design files are)
        B - C:\Cadence\SPB_17.2\share\pcb\pcb_lib\symbols (default location where all Cadence symbols are located)


        Then in PCB Editor, I tried to create the c0805 drawing by following different steps. These are my observations.
        1. Everything default, no change to padpath and psmpath
        - CANNOT FIND the "smd_w0mm95_h1mm35" in package symbol wizard padstack browser

        2. Added directory "A" information in padpath and psmpath (setup -> user preferences -> paths -> library
        - CANNOT FIND the "smd_w0mm95_h1mm35" in package symbol wizard padstack browser

        3. Added directory "B" information in padpath and psmpath (setup -> user preferences -> paths -> library
        - CAN FIND the "smd_w0mm95_h1mm35" in package symbol wizard padstack browser

        4. Paths were kept same as in (3) but removed the "smd_w0mm95_h1mm35" file from directory "B"
        - CANNOT FIND the "smd_w0mm95_h1mm35" in package symbol wizard padstack browser


        CONCLUSION -
        I can only find the custom PAD file when placed in the default Cadence directory for these files. Robert stresses on the importance of placing this file in the project design folder in the lecture. However, when I do this, I no longer see the custom PAD file.

        Please let me know if the observations are the same on your end and if it is okay to place these custom PAD files in the default directory. I have been able to debug all my setup issues in the course so far, except this one which is what is bothering me.


        Regards,
        Vinay

        Comment


        • #5
          This looks to me like somehow your project PATH is not included in the PATHs.

          Just curious, if you rename your path, will it help? Do not use space, maybe use something like C:\Users\vinaygh\Downloads\OrCAD_Lessons and try it again.

          PS: Still, it should not be necessary to add the project path into the ini file. It just should work. I am not sure why it is not working in your case ... I would keep looking for PATH settings.

          Comment

          Working...
          X