Announcement

Collapse
No announcement yet.

How to compile openssl natively - custom version in yocto?

Collapse
X
 
  • Time
  • Show
Clear All
new posts

  • How to compile openssl natively - custom version in yocto?

    I am trying to add the recipe in the yocto to build openssl natively i.e for my host machine - X86. Here is my recipe and my compilation is failing saying circular dependencies. I am unsure what to do next.

    Here is the recipe -

    Code:
    openssl_git.bb
    
    DESCRIPTION = "Potluck with different functions for different purposes that can be shared among C programs"
    HOMEPAGE = "https://github.com/openssl/openssl"
    LICENSE = "Apache License 2.0"
    LIC_FILES_CHKSUM = "file://LICENSE;md5=c75985e733726beaba57bc5253e96d04"
    SRC_URI = "git://github.com/openssl/openssl.git"
    SRCREV = "${AUTOREV}" S = "${WORKDIR}/git"
    
    do_configure () {
      cd ${S}
    ./config
    }
    
    do_compile () {
    # Build openssl
    oe_runmake -C ${S}
    }
    
    BBCLASSEXTEND += "native"
    I get the errors -


    Code:
    cal/lib/ossl-modules\"" -DOPENSSL_BUILDING_OPENSSL -DNDEBUG -MMD -MF apps/lib/libapps-lib-app_x509.d.tmp -MT apps/lib/libapps-lib-app_x509.o -c -o apps/lib/libapps-lib-app_x509.o apps/lib/app_x509.c
    | arm-poky-linux-gnueabi-gcc: error: unrecognized command line option '-m64'
    | arm-poky-linux-gnueabi-gcc: error: unrecognized command line option '-m64'
    | Makefile:3979: recipe for target 'apps/lib/libapps-lib-app_params.o' failed
    | make[1]: *** [apps/lib/libapps-lib-app_params.o] Error 1
    | make[1]: *** Waiting for unfinished jobs....
    | Makefile:3987: recipe for target 'apps/lib/libapps-lib-app_provider.o' failed
    | make[1]: *** [apps/lib/libapps-lib-app_provider.o] Error 1
    | arm-poky-linux-gnueabi-gcc: error: unrecognized command line option '-m64'
    | Makefile:3995: recipe for target 'apps/lib/libapps-lib-app_rand.o' failed
    | make[1]: *** [apps/lib/libapps-lib-app_rand.o] Error 1
    | arm-poky-linux-gnueabi-gcc: error: unrecognized command line option '-m64'
    | Makefile:4003: recipe for target 'apps/lib/libapps-lib-app_x509.o' failed
    | make[1]: *** [apps/lib/libapps-lib-app_x509.o] Error 1
    | make[1]: Leaving directory '/home/shreyas/temp/custom_yocto/build-custom-zynq/tmp/work/cortexa9t2hf-neon-poky-linux-gnueabi/openssl/git-r0/git'
    | Makefile:3055: recipe for target 'build_sw' failed
    | make: *** [build_sw] Error 2

  • #2
    Did you try to add something more simple and just test if it will be successfully added? Just to find out if problem is in the way to adding it or in the openssl itself.

    Comment


    • #3
      The way of adding it since I can build openssl without yocto easily.

      Comment


      • #4
        I can't really help with this much. But maybe have a look at Voipac's repository - maybe they added some software to YOCTO and maybe it will help?
        https://wiki.voipac.com/xwiki/bin/vi...dcustomization

        Comment

        Working...
        X
        😀
        🥰
        🤢
        😎
        😡
        👍
        👎