No announcement yet.

problem with uboot OpenRex SBC

  • Time
  • Show
Clear All
new posts

  • problem with uboot OpenRex SBC

    Hello everyone,

    I'm trying to configure openrex imx6 SBC to create a video server for streaming video from IpCam.
    I followed the "openrex-how-to-start-with-software" guide and compiled and created the image of the customized YOCTO for openrex. I then wrote the image on the SD, and I tested it on the board.
    Now the first problem, if I try to boot from sd with the command:

    "setenv bootcmd 'run bootmmc'; saveenv; reset"

    but nothing happens and just answers me with a error:

    "Error:" bootminc "not defined"

    if instead launch the manual command:

    "mw.l 0x020d8040 0x2840; mw.l 0x020d8044 0x10000000; reset"

    the boot is successful and I can log in as root, and here the second problem, even though it recognizes the ethernet connection, does not allow me to download anything,
    "apt-get not found"

    maybe before I write the sd I have to configure uboot and kernel better?
    could you tell me the right direction on how to proceed to get a right kernel to install the webserver then?


  • #2
    "Error:" bootminc "not defined"
    Depends on what uBoot are you using (e.g. what version or if it is voipac or fedevel etc). Not every uboot has bootmmc defined. You can have a look how it is implemented here (just search for "bootmmc"):

    "apt-get not found"
    this may help you:

    could you tell me the right direction on how to proceed to get a right kernel to install the webserver then?
    this may help you:


    • #3
      Thanks Robert,

      I tried downloading and installing the version with apt-get, as by tutorial, but i always have the bootmmc problem (not defined)
      Also it is not launched by the manual command "mw.l 0x020d8040 0x2840; mw.l 0x020d8044 0x10000000; reset"!

      now I tried to edit the bootmmc, as explained by the link you suggested to me, but I could not find the corresponding file..

      how can I proceed?


      • #4
        You do not need the file. You can run the commands which are under bootmmc manually or you can create the bootmmc by yourself through setenv command. What you only need to know is, what is included inside bootmmc and you can find it here:

        What you are actually trying to achieve? Boot from mmc?


        • #5
          Thanks Robert,
          I tried to start the uboot..and with failure ..
          But now I have another problem, in fact I tried to upload the uboot, but now It does not work anymore..
          so now if I try to launch from SD, I can not see anything via serial, it works only if I boot from usb, but even so, I can not access openrex and exit from uboot.
          Now I'm following the guide, but I have not been able to re-configure the uboot on the spi


          • #6
            this will help you:


            • #7
              A couple of comments:

              1. There is a discrepancy in the help_uboot documentation. The reflash SPI method uses "sf probe 3:2" while the Voipac say "sf probe 2:2".
              The OpenRex uses the ECSPI3, which in software becomes SPI bus #2. However, using the sf probe command without parameters works fine as it finds the SPI FLASH itself.
              sf probe [[bus:]cs] [hz] [mode] - init flash device on given SPI bus and chip select
              2. I have tried to find out what "mw.l 0x020d8040 0x2840; mw.l 0x020d8044 0x10000000" really does, but I end up in the two SRC_GPR9/10 registers with no documented function.
              I guess that this means something for the code executing in the iMX6 internal ROM.
              The iMX6 and OpenRex is meant to be a professional foundation for development.
              So, as lectured and used by many, it really should have been documented or explained in a non-cryptic way.

              3. When buying the OpenRex board from Voipac you will find that several things in the u-boot (v2015.4-2.4) environment has changed.
              I am a bit confused by the versioning here as v2015.10 ought to be the most recent.
              However, errors in the 2015.10 is not to be found in the v2015.4 (e.g. consequently overwriting the ipaddr because of a failing: test ${ipaddr} vs. test -n ${ipaddr}.)


              • #8
                terje, ​I hope this helps:
                1) Yes, that is a good point. There are differences between uBoots.
                2) It is not documented feature by Freescale / NXP. I believe, there is no source outside of NXP to find out what that registers are. I found it on a forum.
                3) VOIPAC has their own software. We recommend to use the VOIPAC software and follow their documentation - they developed the full support for our hardware. If you are getting an error, try to ask VOIPAC if they can help you with that. (FEDEVEL software is mostly used for testing and hw verification - we do not develop full packages of software as we are mostly HW company).