Announcement

Collapse
No announcement yet.

made new imx6 module, how to test if it works?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • made new imx6 module, how to test if it works?

    Hello robertferanec

    I bought the baseboard from voipac and got the imx6 rex module produced using my own drawing. the power and user led goes on and the PMIC seems to be working. I tried to connect using micro usb cable to pc in order to see HID compliant device in managers but ıt does not show up. I tried JP2 for serial downloader both shorted and open and no difference. How can ı check if my board is faulty or working ?

  • #2
    got the imx6 rex module produced using my own drawing ... PMIC seems to be working
    - I am not sure what you mean. Did you manufacture iMX6Rex module by yourself or you redesigned it?

    Comment


    • #3
      I did the same design via your design course and had it manufactured and populated to see if ı could get it working. I think ı had no luck and something is wrong. my voltages all seem to be okay but ı dont see the oscillator frequencies with my oscilloscope. I dont see HID compliant device on pc when ı connect the baseboard + rex module to my pc either.

      Comment


      • #4
        Have a look here, this may help you: https://www.fedevel.com/welldoneblog...board-to-life/

        PS: Also, just would like to note, that the iMX6Rex module license is free for non-commercial use only. So you can build it for yourself, but if you would like to sell it, please let me know.

        Comment


        • #5
          its only non-commercial use. power rails are ok. soc and crystals are not working. would this indicate bad processor ? how else can I check if my processor is not faulty using the baseboard or imx6 rex module.

          Comment


          • #6
            did you check the orientation of you crystals?

            Comment


            • #7
              which crystals are you referring to? Arent all the cyrstals on the IMX6 rex all two pins and have no orientation?

              Comment


              • #8
                Im able to measure the crystals after some careful tests. I do not get HID compliant device popping up on the pc at all though. this makes me think that my rex module is not working. I compiled openrex uboot to sdcard and tried it on a working module and I was able to see the uboot on terminal. I tried this sd card with my imx6 rex module but I wasnt able to see anything on the rs232 port either through my oscilloscope or pc terminal putty. Is it safe to call my pcb board design is a fail?

                Comment


                • #9
                  It is very hard to say what the problem is. The module just should work. There is not really much stuff on the module.

                  Comment


                  • #10
                    Im still on the quest of debugging the card in order to see HID device I believe we use USB0 OTG only so I soldered the USB0 to CPU resistors as shown below. This did not work either. On another board based on SabreSD board theres a DIP switch which can use the EIM Config bus to boot from SD card and also I think activates USB OTG because I do get the HID device pop up when I change the DIP configs to SD settings as shown in table below. The rex doesnt use the EIM bus, it only uses the BOOT_MODE and ı think this is only for booting from RS232. Why does the sabreSD use EIM and rex doesnt?
                    Click image for larger version

Name:	BOOT MODE CONFIG.png
Views:	30
Size:	113.3 KB
ID:	10055Click image for larger version

Name:	DIP Switch.png
Views:	28
Size:	42.7 KB
ID:	10054

                    Click image for larger version

Name:	CPU USB0 to OTG.png
Views:	31
Size:	87.2 KB
ID:	10053
                    Attached Files

                    Comment

                    Working...
                    X