Announcement

Collapse
No announcement yet.

Remove component without removing footprint

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • leighpots
    replied
    Ah that little trick ... all the best regards, Leighpots

    Leave a comment:


  • robertferanec
    replied
    leighpots, this will explain it to you: Altium Tutorial – Variants & Printing PDF Schematic

    Leave a comment:


  • leighpots
    replied
    In your sch attached , I selected Demo1 as variant, c1 & c2 as not fitted but still no go . Your NF parts remain even though they are fitted.
    I only have to click OK and the changes should be made ?
    Maybe another bug in my version of altium ?


    Attached Files

    Leave a comment:


  • robertferanec
    replied
    You can download our open source projects and test it there: http://www.imx6rex.com/open-rex/

    Leave a comment:


  • leighpots
    replied
    Thanks - looks like the component links were blown - no matter what I did - not fitting in the variant even in the PCB - it would not actually do it.
    I wish it would warn you of unmatched links !

    I still cannot get the schematic variants to graphically DNI the schematic view however ... Let me give it a go for awhile and open a new post if I get stuck.

    Regards, Leighpots

    Leave a comment:


  • robertferanec
    replied
    Before you export the 3D model, set variant in PCB. We have done it many times, works oki. Maybe you are using an old Altium?

    Leave a comment:


  • leighpots
    replied
    Thanks Robert and Mariomaster,

    We wish to export 3d model without the components to another package ...

    From the schematic I can make variant not fitted and update PCB however it still shows up
    I can find it under project variants in the pcb fie and make sure that Variant 001 is selected not fitted and the component is unlocked. .
    But the component body is still there in 3D

    I check Variant options - hide not fitted components still cannot get rid of it. I think this only applies to fab drawing but what the heck.
    Perhaps related - the devices do not grey out or indicate not fitted in the schematic - perhaps some other setting enabling variants ?

    Leave a comment:


  • robertferanec
    replied
    leighpots, you need to select variant in the PCB, then it works.

    Click image for larger version

Name:	pcb variant altium.png
Views:	233
Size:	187.0 KB
ID:	5412

    Leave a comment:


  • mairomaster
    replied
    I wouldn't advice that. For a proper design in Altium you always want to keep a good synchronisation between schematics and PCB. Why do you need to delete a component a still keep the footprint? Maybe there is a different solution about that.

    Leave a comment:


  • leighpots
    started a topic Remove component without removing footprint

    Remove component without removing footprint

    Need an easy way to remove the component without removing device footprint. Tried a variant - of not fitted but the component is still there in 3D model.
    Guess I could place footprint instead of component but that's a big hassle as some are IntLib ...anything else ?
    Many thanks , Leighpots
Working...
X