Announcement

Collapse
No announcement yet.

Course : Learn Altium Essentials second edition

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Course : Learn Altium Essentials second edition

    Lesson 4: Doing PCB layout
    My Top Layer color is Red and Bottom layer is Blue. But after placing the components , the color of the component changed to green.


    How to get the respective colors for the components placed in top and bottom layer ?"

  • #2
    They are green because you are violatingthe Design rules. Please go to Room definition rule and assign them to place the components outside the room. You can also get rule violation window on the head on display.

    Comment


    • #3
      As mohsin_qau mentioned, green is the indication for design rule error. However, you do not give information on the error (hence your question on the color).

      If rooms are the problem, then you can remove the rooms too (unless you really need them).
      For me, room are useful for two things:
      - Repeats in the design (copy layout from to another)
      - Special clearance rules on specific areas.
      In Project -> Project options -> Class generation, you can uncheck the boxes for generating rooms. This will prevent rooms from being created each time you update the PCB from the schematic.

      Comment


      • #4
        mohsin_qau Thanks for your answer.
        May I know how can we place the components outside the room. I don't find the option for this in the Altium. Refer the attachment (Capture2.png) for the available options I get from the tool.

        @qdrives Thanks for your answer.
        I have already unchecked the "Generate rooms" before starting the layout. Please check the attachment (Capture1.png) and let me know if I missed out anything.
        Attached Files

        Comment


        • #5
          This option is available in the Design Rules Window. Goto Tools----> Design Rules---->Room Definition

          Comment


          • #6
            In my opinion, don't remove the rooms or Uncheck Generate rooms option. Rooms are very useful tool for the component placement/Copying same Layout placement to another design. So better to place them in your design.

            Comment


            • #7
              mohsin_qau Sorry, I could din't able to find a way to place the components outside the room.
              the menu is different on my side (Altium 20.2.7). check the attachment Caputre4 (it is the screen I obtained through Tools-->DesignRuleCheck --> RoomDefinition)
              Also, check the attachment Capture3 , it shows option to place components within room but there is no option to place outside the room.
              Attached Files

              Comment


              • #8
                Sorry i was wrong. U need to go Design->Rules->Placement->Room Definition. Select the respective room and on the right window pan, Keep Objects Outside. Please find the attached picture for reference.
                Attached Files

                Comment


                • #9
                  I don't have the "Strip_Sheet" in my Room Definition to make the setting. Do I have to manually add it or it is not showing up because I missed out something which is required to have the "Strip_Sheet".
                  Attached Files

                  Comment


                  • #10
                    "Strip_Sheet" was the name of My ROOM in the schematics. I was just sent you sample. Your rooms definition will be according to your name of your Schematics sheet entries. Please see through it in detail and depth, hopefully, you will find in it.

                    Comment


                    • #11
                      I resolved the ROOM issue and set the components outside. Still the problem exists.....
                      Attached Files

                      Comment


                      • #12
                        Siva If you add the room, but then change the setting of it to have the components outside of it, then why have rooms?

                        mohsin_qau So, is the room the cause of the error?

                        Comment


                        • #13
                          qdrives : you are rite..I don't know in detail how the Room works....Also, I am not sure what went wrong as I am following all the steps in the course ...am kind of clueless on the issue.....

                          Comment


                          • #14
                            I would recommend to have a look what exactly is causing the problem. I recently made a video about it:
                            https://www.youtube.com/watch?v=f7GP6NZs0Ok&t=1862s

                            Please, double check if the error really is about rooms.

                            Comment


                            • #15
                              qdrives : Please confirm first is that due to the room definition. To check the errors, you will see the Head uo display at the left top corner of PCB screen. If its disable, you can enable with SHIFT+H shortcut key. It will list all PCB errors. Otherwise, go to Panel button at right bottom corner and click PCB rules and violation. It will indicate the PCB errors.

                              Comment


                              • qdrives
                                qdrives commented
                                Editing a comment
                                I think you meant this for Siva ?
                            Working...
                            X