Announcement

Collapse
No announcement yet.

Help Bringing I.MX6 Board To Life...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Help Bringing I.MX6 Board To Life...

    Dear all, we´re trying to bring out board to life (for an important Automotive Customer)

    https://drive.google.com/file/d/0B7l...FaUk5LRVk/view

    I´tried to connect through serial downloader (USB) and it hangs when Loading Uboot

    We also have UART pads Just in case for debug

    My intention it´s to copy the i.MX6UL-EVK Fuses but changing the SD2 boot device from SD1 (we have the sd on the SD1 bus)

    Who can help us with this process, STEPS....

    I want to perform a DDR Test also

    I´m near to not be in time with customers...
    King Regards


  • #2
    1) Watch the current activities. If your board does something, current will be jumping up and down
    2) Watch activity on the UART pins (connect the scope and see if something is happening)

    If you can see activity on the UART pins, you definitely need to connect console there, so you can communicate with your board.

    Comment


    • #3
      I placed a usb to uart bridge as you see on the attached image but there is no output

      Note that there is no SD card placed on the board and the emmc is empty so i think its normal...

      I think MFG TOOL is unconfigured...

      The wifi Module its placed over the sd card bus so i will remove the wii module and i will insert the EVK micro SD, but the evk uses SD2 and i have the SD/Wifi SDIO bus on SD1 bus ...

      Fuses are also unconfigured

      What steps should i take to bring the board to life ?

      Comment


      • #4
        - When you use MFG TOOL, you do not need to configure anything and you still should be able to boot up into uBoot. You don't even need SD cards, you do not have to setup Fuses, uBoot will be loaded through USB and started automatically

        What I would recommend, before you start with MFG TOOL, try to run calibration (I am not sure if there is calibration tool for your CPU, is there?). If you can pass memory test, that could give you some confidence that your board should boot up when a proper software is loaded. For this calibration utility you should not need even the console.

        Comment


        • #5
          Okay so if I download the mfgtool "AS IS" and i do not configure anything such as the CFG.INI etc..
          If i connect through USB serial downloader (this works) and I press start the uart port should send characters?

          Now It Hangs at Loading uboot stage, the uart sends nothing

          Comment


          • #6
            Did you try the calibration? If you are using DDR3 memories, would recommend to start with that.

            Only if you confirm that you memories are ok, only then I would move to the next stage - especially if you can not see any output now.

            Comment


            • #7
              The Boards Work! there was a short in vref but i fixed!!

              Here calibration results (ATTACHED)


              Attached Files

              Comment


              • #8
                Great job!
                Does it boot into uBoot now?

                Comment


                • #9
                  Yes! It outputs the boot process through UART

                  Comment


                  • #10
                    Fantastic! Great job! You are after the most critical point, .. still a lot of testing, but this was very important

                    Comment

                    Working...
                    X