Announcement

Collapse
No announcement yet.

Sd card image is not generated after bitbake

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Sd card image is not generated after bitbake

    When I bitbake for my board it doesnt generate the SD card image as shown in the video.
    Here is what I already tried based on suggestions from
    Google and Yocto IRC channel

    1)Tried adding
    IMAGE_FSTYPES="sdcard"
    in local conf and bitbaked it again but still no sd card image
    2)Uboot /Filesystem/Zimage is all other files are generated as shown in the tutorial video except the sd card image .

    So what are my options ?

    Manually can I create a SD card image ,what are the commands pls?
    or
    Is there is some other way to use the uboot/FS/kernel files to load on sd card ?

    Thanks in advance

  • #2
    Hmm, interesting. I am not really sure what could be the problem.

    If you are not using uboot on SD card, you can simply just create two partitions on the SD and copy there the files. This may help you:
    http://www.imx6rex.com/open-rex/soft...#compile_yocto

    Especially this is important (it gives you information what partitions you need to create):

    Device Boot Start End Blocks Id System
    /dev/sdb1 8192 24575 8192 c W95 FAT32 (LBA)
    /dev/sdb2 24576 204799 90112 83 Linux


    This gives you an idea how to format the first partition and how to copy there the files:

    sudo mkfs.vfat -F16 -s 2 /dev/sdb1
    sudo mount /dev/sdb1 /media/fedevel/
    sudo cp ~/fsl-community-bsp/build-openrex/tmp/deploy/images/imx6q-openrex/zImage-imx6q-openrex.bin /media/fedevel/zImage
    sudo cp ~/fsl-community-bsp/build-openrex/tmp/deploy/images/imx6q-openrex/zImage-imx6q-openrex.dtb /media/fedevel/imx6q-openrex.dtb
    sudo umount /media/fedevel


    This gives you an idea how to prepare the partition with filesystem:
    http://www.imx6rex.com/open-rex/soft...system/#copied

    I hope this helps. Still, creating SD card image should just work, maybe try a clean installation without any changes and see if it creates the images.

    Comment


    • #3
      Clean install is like elixir of all tech issues .So I tried it twice in different folders with new content. But didnt help.

      What commands does Yocto run to generate the sd card image ? Where can we find them and run them manually to generate it ?

      Tia

      Comment


      • #4
        Please, could you post the exact commands you are running after the clean installation?

        PS: I do not know where exactly they generate sd card image. I would need to search for it - it just worked in my case, so I have never needed to investigate how it is done.

        Comment


        • #5
          hi ,

          After saving new files into directory , I run these :


          source setup-environment build

          nano conf/local.conf
          ****I edit only these 2 values these

          MACHINE=tinker-rk3288
          DISTRO=rk-x11


          IMAGE_FSTYPES="sdcard"

          I add this into the file -save it and then ****


          bitbake core-image-minimal


          Regards
          Nik

          Comment


          • #6
            Ah, so you are not doing it for OpenRex, you are doing it for your own/different board? If you are not using the same freexcale/nxp yocto project which I use, than they may use different settings. In this case, you can try to make the SD card by yourself - as I described in my previous comments.

            Comment


            • #7
              Ok , Thanks I will try and follow the instructions on the link.

              Regards
              Nik

              Comment

              Working...
              X