Announcement

Collapse
No announcement yet.

Counterbore hole in footprint possible?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Counterbore hole in footprint possible?

    I am seeking to create a footprint with a counterbore hole as seen below. The pin will drop into the unplated through hole, and the top flange of the pin will come to rest on the counterbore in the, effectively making the top of the pin flush with the trace on top of the board (the sides of the pin will then be soldered to the trace). I am not sure how, or if it is even possible, to specify such a hole in Altium. Does anyone have any ideas? It is a single-layer board (pre-preg with copper on top).

    Click image for larger version

Name:	image.png
Views:	23
Size:	69.3 KB
ID:	20533

  • #2
    1) It is not so much a question if Altium can do it, but can your fabricator. And do they understand the output that you produce (either automatic or manual documentation).
    For the record, it seems to me that Altium is able to 'design' it.
    2) If it is a single layer board, there is no prepreg involved.

    Comment


    • #3
      Thank you for the response. So, the idea is to somehow capture the idea in Altium, then discuss the feasibility with potential vendors. Do you have any ideas how the counterbore could be generated in Altium? Is there the ability to specify hole dimensions along the z-axis? The only similar thing I can think of is a blind or buried via, where the "hole" is only partially drilled. However, I do not think I could utilize that feature specifically, because such vias are specified using the layers of the PCB- it being only one layer, I would need to somehow specify that the hole should only be partially drilled.

      Comment


      • #4
        Did you check the documentation?
        How about this blog: https://resources.altium.com/p/count...nd-counterbore

        Comment


        • #5
          Thank you for the resource. What the post outlines is precisely what I desire to do. Unfortunately, I seem to be unable to achieve the "Pad Features" in the Properties panel. I will continue to try and might reach out to an Altium rep.

          Comment


          • #6
            What do you mean with "unable to achieve the 'Pad Features' " ? That you do not have the pad features section in the properties panel?
            Have you selected the pad?
            Which version of Altium?

            Or do you mean that you cannot get the specifications the way you want?

            Comment

            Working...
            X