Announcement

Collapse
No announcement yet.

Distributor Part Update

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Distributor Part Update

    I have question regarding altium.
    Let say I have 20 schematic sheets and each sheet has exact same 5 component.
    Now time pass and this component no loner available from the supplier.
    Now I have added new component that has exact same value but has different part number and different manufacturer.

    Question is:
    How can I change outdated component in 20 schematic sheets with new component without going to each sheet and changing each component manually.

  • #2
    Hi lanuser, did you try:
    - Schematic: Update from Libraries -> Fully replace symbols and sheet with those from library ("check" all) -> Next.
    - "Check" all the symbols you would like to replace.
    - Select a component (s) -> Click on "Choose Component" button. Find it in the library and select the new component.
    - Check "Library Name" and "Logical Symbol", if they are correct
    - Finish ...

    Please, let me know if this is what you were looking for. I hope it will help

    Note: You may need to install the library first. Go to your Schematic: Design -> Add/Remove Library

    Click image for larger version

Name:	Update from library 1.png
Views:	17
Size:	281.0 KB
ID:	315

    Click image for larger version

Name:	Update from library 2.png
Views:	15
Size:	257.7 KB
ID:	316

    Comment


    • #3
      Originally posted by robertferanec View Post
      Hi lanuser, did you try:
      - Schematic: Update from Libraries -> Fully replace symbols and sheet with those from library ("check" all) -> Next.
      - "Check" all the symbols you would like to replace.
      - Select a component (s) -> Click on "Choose Component" button. Find it in the library and select the new component.
      - Check "Library Name" and "Logical Symbol", if they are correct
      - Finish ...

      Please, let me know if this is what you were looking for. I hope it will help

      Note: You may need to install the library first. Go to your Schematic: Design -> Add/Remove Library

      [ATTACH=CONFIG]n315[/ATTACH]

      [ATTACH=CONFIG]n316[/ATTACH]
      Your answer are Incorrect.....

      I found the solution ... and will post later on today.

      Comment


      • robertferanec
        robertferanec commented
        Editing a comment
        I am curious. please post it. Thank you.
    Working...
    X