Announcement

Collapse
No announcement yet.

analog and digital gnd routing

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • analog and digital gnd routing

    Hi. I have two gnd in my design. Analog an digital gnd. I connect them in schematic but i want to connect the analog and digital gnd plane in one point in pcb. When i update the pcb, altium remove one of the net name and use one single name for both analog and digital gnd because in schematic, they are conected together but they have different name. Ho i can solve this problem? How you conect analog and digital gnd together and you dont face this problem.

  • #2
    In Altium you can't properly have 2 different nets shorted together - the situation described by you would happen. A walk around that is to have a Net Tie component:

    http://wiki.altium.com/download/atta...o-Use-Them.pdf

    It is not a very elegant solution, since you might need a customised net tie component for every different situation, but this is how it works with Altium. In some situations where you need to tie signals together, it is also practical to use 0R resistor.

    Comment


    • #3
      Thanks so much

      Comment


      • #4
        Hi,

        Try to use ferrite bead or 0R resistor to connect XGND to GND

        Comment


        • robertferanec
          robertferanec commented
          Editing a comment
          hajri_abderaouf, 0R is fine. BEAD in GND can sometimes cause problems (once we had problems during ESD tests - caused by BEAD - the ESD pulse traveled through chip instead of GND and damaged the chip).

        • hajri_abderaouf
          hajri_abderaouf commented
          Editing a comment
          robertferanec
          Thank you robert for the clarification,i'll try to use only 0R resistor in the future.i don't know about ESD problems caused by Bead because the role of TVS Diode,but only for one time Bead create a problem for me it was when i have connect AGND of audio amplifier with GND the sound was full of noise.So when i have replace it with 0R the problem was solved
          So to resume 0R is best solution.
      Working...
      X