Announcement

Collapse
No announcement yet.

Via's not connecting to power planes

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Via's not connecting to power planes

    Hello,

    I am trying to connect GND vias to the power planes on a 6 layer PCB. I am making layer 2 and layer 5 as my power planes. But when I assign the net name to the layer using split planes or polygon pour I don't see the via being connected. Please tell me what should I do.

  • #2
    Is this question related to this one: https://designhelp.fedevel.com/forum...rors#post19545

    Comment


    • #3
      I don't know what Altium version you use, but this how it should work: https://youtu.be/fhiamy6MA8k?t=253

      Once you assign a net name to power plane, it should automatically connect the power planes to vias and pads with the same netname.

      Why do you assume they are not connected?

      Comment


      • Haiderabidi444
        Haiderabidi444 commented
        Editing a comment
        because am get unrouted nets error after running the DRC.

    • #4
      robertferanec the "problem" is when you double click on the layer name, it too will ask about the net connection. However, the short bit i worked with planes for these questions, did not seem to connect the plane to a net. The way you do in the video does work.

      Comment


      • #5
        Hi,

        I am doing the Learn Altium Essentials course (ISL6236A switching mode power supply) and I have the same problems. I am doing the same things as Robert and make L2 and L5 planes. I am using Altium 22.7.1. If I make L2 or L5 active and double click on an empty space nothing happens. If I double click on L2 in the line of layer sets a small window comes up.
        Click image for larger version

Name:	image.png
Views:	126
Size:	6.3 KB
ID:	20432
        Here I set the net to GND, but nothing happens. (I still have connection problems in the GND net)

        For me the vias are strange. If you look at their properties they are connected to GND net, but L2 and L5 are not shown in the via stack:
        Click image for larger version

Name:	image.png
Views:	120
Size:	34.4 KB
ID:	20433

        If you look at them in the layer stackup L1 and L6 are nicely connected but I am not sure about the other layers.
        Click image for larger version

Name:	image.png
Views:	121
Size:	44.8 KB
ID:	20434
        Can someone tell me what is wrong? Why the GND vias are not connected?

        Thanks,
        Janos

        Comment


        • #6
          could you attach a screenshot of L2 with zoom on a GND VIA? Don't forget, once the layer is set to Plane, these are NEGATIVE layers (any object on this layer shows where the copper is removed), so connection looks different from how it looks on signal layers which are POSITIVE (any object on this layer shows where the copper is added).

          Comment


          • #7
            Hi Robert,

            Please find the image attached.
            Click image for larger version

Name:	image.png
Views:	119
Size:	26.5 KB
ID:	20437

            I uploaded the PCB file in ZIPed version also. You can look into it. If you will be able to look at the PCB file could you also check the tracks? I have numerous clearance violations where overlapping tracks are reported belonging to the same net. In my eyes, both tracks belong to the same net and they together form the connection between pads.
            Click image for larger version

Name:	image.png
Views:	117
Size:	24.3 KB
ID:	20439
            Thank you in advance.
            Janos

            Comment


            • #8
              I don't know why, but there is something wrong with split planes in your design. Please, try to create a new pcb with a plane just to check if it will work. When you are on the plane layer, the layer should have a little color + you should see something like Split plane Count 1 or more. Possibly try to open my original project if you will see it correctly.

              In the background, there is a good pcb, in front there is your pcb - see the differences:

              Click image for larger version

Name:	split planes.png
Views:	136
Size:	152.4 KB
ID:	20441

              Comment


              • #9
                Hi,

                I restarted the PCB design from the end of Lesson 3 and fortunately I was able to find the root cause of the problem. Indeed, if you exactly follow what Robert does it will work. However, a little difference makes a huge difference. The important thing that when you double click in the empty space on L2 (or L5) your selection filter must be in All-On state (at least the "Other" option should be enabled). Under this circumstance the "Split Plane" dialog box will appear, and you can select the net. The vias will immediately connect to the selected net. On the contrary, if you double click on L2 down in the layer sets line, a very similar dialog box called "L2 properties" will come up where you can also set a net. However, this dialog will not result in automatic connections.


                Click image for larger version  Name:	image.png Views:	0 Size:	6.9 KB ID:	20481
                Click image for larger version  Name:	image.png Views:	0 Size:	7.4 KB ID:	20482

                Comment

                Working...
                X