Announcement

Collapse
No announcement yet.

Doubts in Switching Power Supply Design (Version 2) Course Regd

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Doubts in Switching Power Supply Design (Version 2) Course Regd

    Hello Robert,

    I recently finished looking at the all the videos of Switching power supply design (Version 2). I have also finished doing PCB Myself. I am using ALTIUM 18.0 for PCB Design. During the course i have got few doubts and few options i could not see.

    1) Tenting of Via's option : I could not find in Altium 18.0. I am attaching the Pictures along with this mail ( Tenting Doubt.jpg and Tenting Doubt 2.pg). I am not able to find anywhere Tenting option of Vias. So How to do Tenting in ALTIUM 18.0

    2) When I look at the PCB in 3D I see that the Polygons and Tracks are not covered with green color (Solder Mask), is it by default in ALTIUM will not show in 3D? or any settings needs to be changed?. I thought the polygon and tracks should be masked. But that's not what I am looking in 3d in Altium. I have attached the picture of that as well with this mail ( Solder Mask Doubt.jpg)

    3) While in View Mate when I double click on .TXT layer, I am not able to see any holes which are present in the PCB I am only seeing something at the origin that's it. I have attached the pictures for that as well. ( View Mate doubt 1.jpg and View Mate Doubt 2.jpg). So what settings might have been missed?

    Please have a look at these doubts and please suggest me the answers for the same

    Thank you

    Vijaymahantesh V Surkod

  • #2
    Hey, I am no Robert, but:
    1. Click in via - that tab -it will open properties panel (you got it on your right on first pic) and scroll down. There will be Mask opening parameters and just check "Tented". U may also use "find similar object command" on via, filter them an switch it on for all vias u would like.
    But judging Second Picture you just used Pads instead of vias. And pads can not be tented.
    2. Polygons and tracks have mask option too. In 2D mode switch to the TopSolder layer and take a look. Keep in mind that Mask is negative layer, so is there is a geometrical figure on that layer mask will not be on PCB in that place. Also 3D view hides mask and show copper when you highlight (CTRL+Click) the net.
    3.Try to open it with AD's Camtastic, but i thing you either exported or imported it incorrectly. There must be more than one drill file: DRR - description file and TXT with coordinates.

    And in first Pic I can see unconnected plated holes which breaks the polygon, what are those?

    Comment


    • #3
      Thank you beamray for helping to answer the questions. I only would like to add:

      1) I believe, in some specific Altium versions Tenting option is not there (a bug?)
      2) As beamray suggested, could you double check that on Solder mask layer directly?
      3) Check this (Viewmate doesnt show mm correctly, but the file is ok): https://designhelp.fedevel.com/forum...viewmate-issue

      ​​​​

      Comment


      • #4
        Thank you beamray and robertferanec for your reply

        1) It is a Via only (and not a Pad). I have a Altium 19.1.7 in my college Lab computer (Academic Version) where The Tenting option is available and I have checked the Tented option as shown in (Via_1_Tent.jpg) (This I have shown only for 1 particular Via but i have done this for all VIA'S). But Even after using Tented Option when I look at the board in 3D the Vias look exposed there is no solder mask on the vias in the TOP LAYER (3D View) (This figure is shown in Via_2_Tent_TOP_Layer.jpg), while if I look at the Vias in the bottom layer (3D View) the Vias look Tented (This figure shown in Via_3_Tent_Bottom_Layer.jpg . is it a bug or settings needs to be changed?

        2) I have not used CTRL+Left Click on any Net to begin with, Now TRACKS are masked (I have shown the properties panel in figure Track_Mask_2d.jpg) which is also visible in 3d (Track_Mask_3d.jpg picture). But I am not sure how to mask the Polygon? There is not option i am able to find where Solder mask option or Paste mask option mask was available on the properties panel (I have double checked) when I select a particular polygon, Still in 3D view the Polygon does not have a MASK. So how to achieve the masking of Polygon? (Please if possible you could share a picture of where a particular option is available would be a great help).

        and beamray you asked the below question

        And in first Pic I can see unconnected plated holes which breaks the polygon, what are those?

        The answer is Those are Vias connecting the bottom layer to inner layers.
        Attached Files

        Comment


        • #5
          vijay may I ask you to attach PCB file here? I think it will be the easiest way to find out.

          Comment


          • #6
            Maybe the L1 layer is highlighted?

            Click image for larger version

Name:	L1 highlighted.PNG
Views:	47
Size:	45.6 KB
ID:	13790

            Comment


            • #7
              beamray I am not able to attach my project files here (as it saying I am not allowed to attach such files). robertferanec No the highlights option is off only. I have attached a pic for that.
              Attached Files

              Comment


              • #8
                You can zip it (remove history and preview). It should be possible to upload zip (if not, you can just send it to me).

                Comment


                • #9
                  I have sent you the project files by mail. I am not able to attach .rar files as shown in the picture.
                  Attached Files
                  Last edited by vijay; 04-24-2020, 04:25 AM.

                  Comment


                  • #10
                    Just opened your project, looks oki. There is something probably set in your view. This is what I see when I opened your project:

                    Click image for larger version

Name:	highlighted layer - working.png
Views:	42
Size:	263.5 KB
ID:	13812

                    Comment


                    • #11
                      Just in case, I am attaching the same picture but with View Configuration -> View Options TAB visible ... check the settings in your Altium (press L)

                      Click image for larger version

Name:	with view options settings.png
Views:	46
Size:	235.1 KB
ID:	13814

                      Comment


                      • #12
                        I have the same configurations. I am attaching the file here
                        Attached Files

                        Comment


                        • #13
                          And when you change the Configuration to for example to Altium 3D Blue? Still the same?

                          Comment


                          • #14
                            Yes No change. I am attaching the file here.
                            Attached Files

                            Comment


                            • #15
                              Then, I do not really know. Hmm, I see, that you are using AD19, maybe a bug?

                              PS: Still, notice the layer is like above silkscreen - it is like the layer is activated or something like that.

                              Click image for larger version  Name:	active layer.PNG Views:	0 Size:	152.0 KB ID:	13825

                              Comment

                              Working...
                              X